Can't load Flash page in any browser

Discussion in 'macOS' started by Captain Dynamo, Jun 18, 2011.

  1. Captain Dynamo macrumors member

    Joined:
    Apr 21, 2011
    Location:
    Northern California
    #1
    Hi,

    I'm running 10.6.7 on an early 2011 Macbook Pro.

    I can't load a flash page (Weightwatchers plan manager) in any browser I've tried (Safari, Chrome, Firefox, Opera). Here is the link:
    http://www.weightwatchers.com/plan/mgr/PlanManager.aspx?deepLink=deepLinkToFoodTracker
    (probably won't work for you unless you have a Weightwatchers log in)

    The flash page will load in Chrome on a PC on the same network.

    What am I missing?

    Many thanks!
     
  2. Captain Dynamo thread starter macrumors member

    Joined:
    Apr 21, 2011
    Location:
    Northern California
    #2
    Replying to my own post

    I resorted to Applecare and was helped by a savvy specialist. He identified it as an Adobe Flash problem. We uninstalled that, reinstalled, played with the settings and it still wouldn't work.

    I finally upgraded an old copy of VMWare Fusion, set up a virtual Ubuntu machine, and got Chrome and Flash running on that. I can access the site now, but this was the really long way around!
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    You should be able to fix this by uninstalling flash and making sure anything flash-related is deleted from your Mac. Go to /Library/Internet Plug-Ins on and delete "Flash Player.plugin" and "flashplayer.xpt". Go to Users/yourhomefolder/ Library/Internet Plug-Ins. Look for "Flash Player.plugin" and “flashplayer.xpt,” and delete the files if they are located there. Then reinstall flash from the dmg file (in other words download the dmg before doing this, since you don’t want to have a browser open when you do this).
     
  4. Captain Dynamo thread starter macrumors member

    Joined:
    Apr 21, 2011
    Location:
    Northern California
    #4
    Thanks for the tip--alas, didn't work.

    I went wild with security settings a couple of months ago and wonder if I did something then that had this result. Some global setting that affects everything. Flash of course is the obvious candidate. Tried turning off the firewall, no impact...
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  6. Captain Dynamo thread starter macrumors member

    Joined:
    Apr 21, 2011
    Location:
    Northern California
    #6
    Per your suggestion, tried it. Lots of activity, lots of permissions to be repaired, but still can't load the flash page. Thanks anyway!
     
  7. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #7
    I went back and read the OP. Is this the only page you can’t load in flash? If so, perhaps the site is down or they screwed up the flash page.
     
  8. Captain Dynamo thread starter macrumors member

    Joined:
    Apr 21, 2011
    Location:
    Northern California
    #8
    Aggie, thanks for your patient and persistent help!

    This is the only page on which I've experienced this. Inspired by your question, I checked out some Flash test pages and they indicated that my Flash is installed etc. However, I noted that on some pages Javascript requires permission to run. I wonder if that could be a problem here: Javascript permission needed but for whatever reason the page isn't asking for it so I'm not granting it. But the fact that it doesn't work on any of the four browsers I tried mitigates against that.
     

Share This Page