Can't load large games on my iPad

Discussion in 'iPad Tips, Help and Troubleshooting' started by danieliew, May 24, 2011.

  1. danieliew macrumors newbie

    Joined:
    May 24, 2011
    #1
    Hi, I was wondering if anyone else here is facing the same issue as I am. I've recently installed Infinity Blade and Real Racing 2 HD on my iPad. But each time I load the game, it just plays the intro, then quits to the home screen. I've so far only managed to go into the game once or twice. I've tried quitting all the other running programs but still the same....
    I noticed that both these games are very large in size. I don't see the problem for smaller games though.
     
  2. patrickj macrumors regular

    Joined:
    Sep 25, 2007
    Location:
    Texas
    #2
    I've played Real Racing 2 HD and not seen any issues loading it. Have you tried a hard reboot to give the iPad a completely fresh set of resources to allocate to the game?
     
  3. patp Guest

    Joined:
    Apr 10, 2008
    #3
    sounds like the ram is maxed. Try clearing out any open apps in the app drawer (double press home button, long press any icons in the tray and dismiss)

    and like the other poster mentioned, hard reset.

    Also look at your available storage. Are you closed to maxed out? Try removing some unused media.
     
  4. danieliew thread starter macrumors newbie

    Joined:
    May 24, 2011
    #4
    Thanks for all your replies. I've already quit all background apps and the available ram is usually above 100mb. I've got more than 30gb storage since I'm using the 64gb iPad. I've also tried rebooting or respringing my ipad but still no good. By hard resetting, do you mean re-initializing my ipad? By the way, I'm running a jailbroken 4.3.3 ios.
     

Share This Page