Can't log in *at all*, except in safe mode. Beta install gone badly wrong.

Discussion in 'OS X Yosemite (10.10)' started by evilplan, Jul 28, 2014.

  1. evilplan macrumors newbie

    Joined:
    Jul 28, 2014
    #1
    Hi everyone

    Yosemite beta has been pretty bad for me :-(

    I installed the public beta 4 days ago. I had the same problem a lot of people are having - it took 3-4 hours to install on my early 2011 MacBook Pro (with 80gb free space), with no indication of what was happening.

    Once it installed, it went badly wrong. I cannot log in. The login screen flashes every 2 seconds, as if it's a TV being tuned in. Then it goes back to the login screen. There's a permanent spinning ball. I can type my password (although it takes minutes for the letters to appear in the password box) but nothing happens after I press enter. I've waited for a few hours.

    I can log in with Safe Mode - although when I log in, I get the 'processing' icon (the one with thin lines in a circle like a clock), often for 3-5 minutes. But once it logs in it's a disaster area. Most programs are unstable - I don't know whether that's cos of the restrictions of Safe Mode or whether it's part of the same problem: Browsers can only use basic fonts, I can't watch any video, iMessages is taking 48 hours to display messages, Safari won't load, pages won't load in Chrome; spotlight won't display any apps. Finder crashes all the time - in fact if I load up Activity Monitor, there's always at least 4 apps 'not responding' - SystemUIServer, iCloud Photos, loads of things. The system is unstable - sometimes it simply stops working.

    Can anyone give me any advice please? I believe I've reset PRAM and NVRAM. I've been hunting for people who have had the same problem, but haven't had any luck.

    Here is the video (just a shot of the screen): http://youtu.be/tx5PYswzLAc

    I've got a full backup, I'm not worried about that. The downside is, I had to leave my house to look after a sick relative, so I've got to live with this install for a week.

    Has anyone experienced the same problems? Is there anything I can do with this installation, or am I screwed and need to reinstall Mavericks from scratch?

    If that's the case, I'd really appreciate it if people could point me to an easy-to-follow guide showing how to revert back to Mavericks - I just want to make sure I don't mess up the reinstall.

    Thanks for your advice everyone. I've never had this kind of problem from an Apple beta before. I'm not criticising Apple for this - I knew what I was getting into and I'm secure with everything backed up. It's just a pain that I've got to wait a week before I'm able to reinstall. So, any advice on how to fix the bad install would be really appreciated.
     
  2. seanrik macrumors newbie

    Joined:
    Jul 28, 2014
    #2
    Clean install required

    on MBP with two graphics cards there is an issue with the extensions for the AMD or ATI cards. If you upgrade rather than doing a clean install on a separate partition or hard drive it does not update the extensions in the system folder. If you do a clean install then it works no problem. With beta software, or any major upgrade, it is always prudent to do a clean install and then migrate across from a backup your other files.

    If you can, restore back to pre Yosemite and then perform a clean install and then transfer your files and applications across. You could try moving out the files in the /System/Library/Extensions that start with AMD and ATI out to a directory called Disabled extensions or something similar. You should be able to start normally, but things will still not quite be right. You need to find a way to get your system back to ML first.
     
  3. evilplan thread starter macrumors newbie

    Joined:
    Jul 28, 2014
    #3
    Hi seanrik, thanks so much for your response. This definitely felt like a graphics issue but I had no idea how to resolve it.

    I'd like to report it as a bug, but I can't even get 'feedback assistant' to run - it freezes :)

    If I've understood you right, your advice is about what to do to get a proper install next time, is that right?

    Do you have any idea if I can do anything about this install, or do you think I'm screwed? It sounds like you're saying I have no option but to go back to Mavericks.

    I'm not really clear how to get back to Mavericks, to be honest. From what I can see, it's not possible to just roll back - it sounds like the only way to do it is a clean install. If you have any advice, I'd be grateful.

    But the main thing is, I just want to be clear that you're saying I can't do anything with *this* install? I'm wondering, for example, if I can completely disable the discrete graphics card and tell it to only use the built-in graphics.

    Thanks again for your post, it's really helped me understand what's happening.
     
  4. seanrik macrumors newbie

    Joined:
    Jul 28, 2014
    #4
    Disabling the graphics card will not work, I think. The issue is the extensions not being updated to the latest versions. Your best bet at this time is to start over. What did you use to make your backup?

    To start over I would boot in to the recovery partition by pressing command R. this will allow the computer to start and then you can begin the repair. Thankfully you have a backup :)

    You have two options. If it is a Time Machine backup, use the restore from Time Machine option and then connect to your back up and return everything back to pre Yosemite. This will wipe your current install.

    If you still wish to install Yosemite, you need to do a clean install, which means you need to put it on a different hard drive to your laptop hard drive, or use disk utility to partition your hard drive and install yosemite on to the new partition.

    http://blogs.computerworld.com/mac-os-x/23987/get-your-mac-ready-os-x-yosemite-beta-installation

    tells you how to partition hard drive

    http://www.macworld.com/article/1165784/how_to_restore_data_from_time_machine.html

    how to restore from time machine - see about half way down

    Your other option is to use disk utility when you are in the recovery partition and wipe your disk and then use the option to install the new OS and then boot in to and put back in items from your backup.

    Personally I would use the first option, as it gives you two systems, which you know one of which will work as it is your ML setup.
     
  5. evilplan thread starter macrumors newbie

    Joined:
    Jul 28, 2014
    #5
    Hi again seanrik, thanks for responding.

    I used 3 different backup methods - Time Machine, a Synology client sync program that copies everything over to my NAS, and backblaze cloud backup. One thing I never want to muck around with is backups :)

    Sounds like the easiest option would be your advice re restoring from the TM backup. Once I've got things back up and running, I'll work out the method I want to use to install Yosemite. It's funny, for some reason I hadn't even clicked that I could restore fully from TM. It was definitely worth me asking the question - it's funny what you forget.

    I wonder why this has happened though - in the sense of, why would Apple allow a beta to come out that can cause so much damage by not updating kext files. I don't know enough about it to know if that would've been easy for Apple to deal with; maybe it's one of those impossible-to-resolve issues.

    I'm really grateful to you for taking the time to help out - I understand more about what's gone wrong and I'm not gonna carry on trying to see if I can "fix" it. I'll just muck around in Safe Mode til I get back home to my nice, safe, warm TM backup :)

    Thanks again
     
  6. seanrik macrumors newbie

    Joined:
    Jul 28, 2014
    #6
    We have all been thankful for backups at some point in the past. The software is a beta, so there will be many bugs and kinks in the system. There is always the chance of more problems when you apply a major update over an existing system and more so with a beta release. I guess most developers, who have been reviewing the software, did clean installs, but this is the purpose of beta testing. Hopefully you will be able to post a bug to apple when you get up and running. Usually software does check the version of the different files and the new files are in the install. I know when the final version is published I will be doing a wipe, clean install, and then use the migration assistant to transfer everything across from time machine. Takes longer, but less chance of third party installations causing issues, but the installers from apple have got better, with incompatible programs etc getting moved during the install.

    If you have a backup at home, you could boot in to recovery partition and then wipe the drive and install the OS afresh before you get home. this will more than likely give you a working Yosemite install. You can then use migration assistant when you get home to restore other programs and documents. Depends on whether you need any files while you are away. I tend to make sure I have important docs in the cloud, so I can access from anywhere.

    What I can say, despite this issue, I have not had any issues with software not working from third parties and things seem faster and smoothly. I like the upgrade but I am pleased I partitioned my HD so I have a mavericks and Yosemite install, which means I can easily switch between them by holding down the option key on boot.

    I did consider suggesting you partition the HD whilst in safe mode, but not sure if you could. If you could you could then install a fresh copy of Yosemite on the new partition and then transfer the correct extension files across to the broken install. However, there could be other files that need updating, so a fresh start is always best when these things go wrong.
     
  7. thedeejay macrumors 65816

    thedeejay

    Joined:
    Aug 16, 2012
    Location:
    Toronto, Canada.
    #7
    You can try the Cmd+R option at boot up to see if it lets you install Mavericks but most people have reported that it doesn't. Your next best bet is to install Mavericks (make a bootable USB), clean install Mavericks and then restore your stuff from time machine. Is this your 'spare' Mac?
     
  8. seanrik macrumors newbie

    Joined:
    Jul 28, 2014
    #8
    I had been using a clean install on a new partition. Since my last post I decided to try transferring data over from a TM backup to see how things would be. I got the same problem you experienced. I suspect there is another extension that is causing the problem too. The clean install works with the MBP early 2011, so not a problem per se with the beta. I would still advise installing on a separate partition. Add in things gradually. If like me you have upgraded quite a number of times over the years, there could be many things lurking in the system folder that get transferred across. I am going to do a test and just transfer across the documents from time machine, rather than applications, and see what that does. If that works, then know it is an issue with a kext file.
     
  9. seanrik macrumors newbie

    Joined:
    Jul 28, 2014
    #9
    do consider what third party startup items etc you might have installed or that have modified your system - check in the library and the system->library folders for items in launch demons, launch, Agents, startup items, application enhancers. Some software like audio hijack pro and remote buddy install items in these places that load during startup before you login. What I did notice is that after the clean install and transfer of items, it started up no problem. It was only after shutting down and starting up again that the bug showed itself.
     
  10. bit50man macrumors newbie

    Joined:
    Jul 19, 2012
    #10
    Same happened to me...

    I have installed the beta twice. Installation goes fine and even allows me to reboot and login but after some time on a reboot I got the same as you.

    Followed advice seen on this forum;

    rebooted cmd -s and entered the following;

    mount -uv /
    rm /var/db/.applesetupdone
    shutdown -h now

    on reboot you go through a new setup.. this allows you to boot back into your previous account. That said, I've had to do this three time and in the end have gone back to maverick.
     
  11. edjusted macrumors newbie

    Joined:
    Sep 10, 2010
    #11
    Sounds similar to/the same as http://forums.macrumors.com/showthread.php?t=1758497

    This fix worked for me:
    I had the same problem over the weekend. Drove me nuts. I also tried to do a clean install, etc. It worked on the first login then the problem started back up after subsequent reboots. I fixed it by rebooting in safe mode (hold down the shift-key while booting up), logging in, going to the Energy Saver preference panel and turning off "automatic graphics switching" option. (I found mention of this on another forum).

    FWIW, I turned it back on later and haven't had the problem come back again, knock on wood. Also, I noticed that if you turn on auto login so it bypasses the login screen, the problem doesn't seem to show up.
     

Share This Page