Can't log in to Mac App Store

Discussion in 'Mac Apps and Mac App Store' started by kajitox, Jul 20, 2011.

  1. kajitox macrumors 6502a

    kajitox

    Joined:
    May 2, 2007
    #1
    Hey everyone, this has been a problem since the MAS release, but has become a bigger issue now that Lion has been released. I've never been able to log in to the MAS and all of the resources online have never produced a solution for me. Most hits online say you have to do a simple restart of the program or computer, then they go on to say that the problem is with something called FruitMenu being installed. There are two programs that people list as problematic, and they have never been installed on my machine.

    Whenever I open up the MAS, I attempt to go through the menu to sign in, or buy an app hoping I'll be prompted, or trying to sign in through the "purchases" page. No dice...

    Anyone experiencing similar problems? Anyone have a fix, or a link to a fix? Google has been useless and all the searches on MR just turn up with a thousand articles about Lion, but not about sign-in issues.

    Thanks!
     
  2. rebamac macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    GA
    #2
    Cannot log in to MAC App store - Computer not recognized

    I have a very similar issue. I just upgraded to Snow Leopard 10.6.8 (iMac) and upon accessing the Mac App store, I receive an error msg stating "Your device or computer could not be verified. Contact support for assistance." So I have emailed Apple in hopes of finding a solution.

    I was even able to go to iTunes and make purchases from this computer and even selected authorize this computer, but no dice.

    Does anyone have any suggestions?
     
  3. kajitox thread starter macrumors 6502a

    kajitox

    Joined:
    May 2, 2007
    #3
    Ah, see I dint even get that far. Every capability that I have to sign in doesn't even respond. These issues are widespread - it's interesting I can't find more help for it.
     
  4. steveoc macrumors regular

    Joined:
    Nov 6, 2007
    Location:
    Adirondacks NY
    #4
    The first thing is to go to Library/Preferences/SystemConfiguration/ and delete NetworkInterfaces.plist, then reboot.

    If that doesn't work, it may be that you are using a nonstandard network interface as was the case for me. A power surge fried my built in ethernet ports, so I threw in a 3rd part ethernet card. App store refused to work with it--I got the same results as you. Once I had the computer repaired and was able to use the built in ports, it worked once I deleted the NetworkInterface.plist file and rebooted.
     
  5. kajitox thread starter macrumors 6502a

    kajitox

    Joined:
    May 2, 2007
    #5
    No dice. It's nice to have a suggestion, though. Thanks for the try! Back to scouring the googs...
     
  6. kajitox thread starter macrumors 6502a

    kajitox

    Joined:
    May 2, 2007
    #6
    Since I hid the icon from my tray, I completely forgot that I had Little Snitch running. Once I disabled it, it works just fine.

    Best of luck to anyone who reads this!
     
  7. yeuking macrumors newbie

    Joined:
    Mar 2, 2012
    #7
    Just some info....

    For those still Can't log in to Mac App Store or can't activate iMessage, please make sure your LAN or Wifi and Graphics Card is detect by OS X.
    As ex. below:-
    [​IMG]
     
  8. deedubya macrumors newbie

    Joined:
    May 31, 2004
    #8
    This worked for me got me up and running in no time at all
     
  9. darksideup macrumors newbie

    Joined:
    Jul 2, 2012
    #9
    After months of searching for the answer to WHY I wasn't able to sign into my app store, and having my app store deleted, and then again reinstalled. And to have it all fixed by simply turning OFF my Little Snitch..

    I did an audible WHOOP when it worked. :D

    THANK YOU FOREVER!
     
  10. eventproducent macrumors newbie

    Joined:
    Sep 24, 2012
    #10
    :):):):):):) THANX!!!! I was searching for months too.

    (@apple helpdesk????)

     

Share This Page