Can't log into account

Discussion in 'macOS' started by Jynlyn, Jul 12, 2011.

  1. Jynlyn macrumors newbie

    Joined:
    Jul 12, 2011
    Location:
    Wichita, Ks
    #1
    When I log into my account it takes me to the my desktop but will not load my desktop icons. It then returns me to the log in screen. I can however log into other accounts. I set up a new admin but cannot access my old files because I do not have permission. I've tried repairing permission (which fails). I've tried repairing permission through the install disc and it stalls...all day. The Mac HD appears to be ok when I verify Disk. I've also tried to just do a reinstall but it fails to. Any help would be greatly appreaciated! I'm running Mac OS X 10.6.7 on a MacBook.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #3
    Everything from here on assumes you don't want to wipe your system and start over. If that is the case, skip to the bottom and see my reply to the other guy's post.

    Are any of your accounts that you can log in to admin accounts? If so, you should be able to reset the login items of the broken account so you can log in. Even if this is not the case, you should still be able to use the broken account to get stuff done, even from one of the non admin accounts.

    Why? Because I don't think it's a password problem or you would never see your desktop in the first place. Try the following...

    Log in as one of the accounts you can access and open terminal and do the following...
    su yourproblemaccount
    yourproblempassword (when prompted)

    You should be sitting in a terminal prompt logged in as the account that won't load. If this works, there are things you can do to recover.

    You can now open system preferences from any account and go to accounts. Click the padlock to "make changes" and it will prompt you for your admin account user name and password. You should now be able to delete any log in items associated with the account you are having problems with. Also note that repair permissions doesn't really fix everything. Let's say a vital config file you need to log in had its permissions set such that you can't read the file. This could cause the half login followed by being thrown back to the login prompt. To fix this, browse to the home folder of the problem account and pick the folder you are having trouble with and pick "get info". Scroll down to permissions and make sure the account you are having problems with has permissions on its own home folder. This next step is important... Click the checkbox for "apply to enclosed items" and when it starts churning, go for a walk and get your self a cup of coffee. You might have time to plant coffee beans, grow them, roast them, grind them and brew them but the point is that once it finishes, any files in the home folder that should have been readable by that account should now be fixed. You could try "fast user switching" to see if you can now log in to that account while leaving the account you were using to do the repairs open in case you still can't get in. Let us know how it goes.

    I assume he wants to keep his data but if he doesn't care about his data he should pop in his DVD, pick erase and install and be all set. I sure hope he has his stuff backed up somewhere (besides Time Machine which can be a bit finicky).
     

Share This Page