Can't log into iCloud prefpane, wrong pass. All other services works fine.

Xavio

macrumors newbie
Original poster
Jun 16, 2009
11
0
I tried to access my iCloud settings prefpane just to check some settings, but it just wouldn't accept my password. I changed it last week, so it was quite fresh in my head. Somehow i thought changing it again would help, but nope. It didn't.

Then I called the Apple Support and we created a new user on my Mac. This user can access the prefpane.
So it's my user stuck with the problem.


So all in all.

OS X 10.7.2, no new updates.

I can't access the iCloud settings in Preferences from the primary user account on my Mac.

I Can access my account on apple.com.
I Can access iCloud.com.
I Can access my account details in iTunes.
My iPhone accepts my password in the iCloud settings and everythings fine.


Anyone heard of this before? :confused:
 

IlyaKamens

macrumors newbie
Jul 25, 2011
3
0
I have the same problem

I can log in:

• on http://www.icloud.com,
• on my iPhone, and
• on my iPad.

I can log in anywhere except in the System Preferences iCloud pane. Very bizarre and frustrating. When I try to log in via System Preferences, it either says that my password is incorrect or it just verifies my password for a seemingly infinite amount of time.

Any help would be greatly appreciated.
 

wordsmith27

macrumors member
Oct 15, 2011
30
0
I can log in:

• on http://www.icloud.com,
• on my iPhone, and
• on my iPad.

I can log in anywhere except in the System Preferences iCloud pane. Very bizarre and frustrating. When I try to log in via System Preferences, it either says that my password is incorrect or it just verifies my password for a seemingly infinite amount of time.

Any help would be greatly appreciated.
I'm having the exact same issue
 

cullenmk

macrumors newbie
Dec 11, 2011
2
0
Hey all, I was able to resolve this issue by deleting the contents of user/Library/Application Support/iCloud/Accounts/

Hope this helps.
 

cromaducale

macrumors newbie
Jan 4, 2012
1
0
Solved!

i got same problem. Cleaning Library prefs don't works for me. after mumbling i tried to switch off little snitch, and it... works! iCloud pref panel need answers to his calls at icloud servers. if they don't arrives the panel don't allow you to access.
so... switch off your firewalls, net filters etc. log in, yhen you can switch on again filters.
 

Sabbac

macrumors newbie
May 17, 2010
2
0
Not solved... :(

I have the same issue, when I login to iCloud in the system preferences, It just spins, never connecting. I deleted the files listed, and it's not a firewall issue. I can log into the website and from my iPhone and iPod. Any ideas?
 

Phredd

macrumors newbie
Mar 11, 2012
1
0
Folsom, California
iCloud Log-in problem through System Prefs

I had the same problem, tried deleting system preferences plist, mail preferences, re-installed Lion, etc., finally through a combination of MacRumors, MacWorld and Apple Support forums, and a call to Apple support found deleting the "Accounts" folder worked.

Users>username>Library>Application Support>iCloud>Accounts

Then restarting, solved everything didn't even have to sign in to System Preferences.
 

MaartenS

macrumors newbie
Apr 4, 2012
1
0
I don,t have a iCloud Accounts folder

I had the same problem, tried deleting system preferences plist, mail preferences, re-installed Lion, etc., finally through a combination of MacRumors, MacWorld and Apple Support forums, and a call to Apple support found deleting the "Accounts" folder worked.

Users>username>Library>Application Support>iCloud>Accounts

Then restarting, solved everything didn't even have to sign in to System Preferences.
I don't have this folder (not even hidden). I also can't login to the mail through the iCloud website. I'm able to login on iCloud, but when I click the mail button I doesn't work. Help!
 

Transeau

macrumors 6502a
Jan 18, 2005
869
12
Alta Loma, CA
Here is your fix...

I've had this problem several times in the last year, after having it escalated several times, Apple's iCould techs have a solution... The problem is with the "Apple Token" that is used with the IMAP server. Here is the solution.

1) come up with TWO new passwords, make sure you meet the requirements. (8 characters long, at least 1 number, at least one capitol, no repeating letters) - You *WILL* need one, you *MAY* need two.

2) Log in to manage your Apple ID and change your password - https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/

3) Check and see if that worked. Some accounts will be fixed now. Others may need a call to Apple, if so, continue.

4) Call Apple Support, Get a Tier-2 iCloud Support Tech. Tell them you need the account put into "Troubleshooting Mode" and the password reset. They will verify your security question as well as your billing address.

5) Reset your password with the email the tech sent you to an alternate address.

Many will be fixed by step 3. I was able to fix 2 of my accounts like that, 3 of them had to be fixed by Apple's reset.

It appears that the "Apple Token" gets corrupted and they have no way to regenerate the token without a password reset.

Hope this works for you all.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.