Resolved Can't login anymore (fault with home map on external disk)

Discussion in 'OS X Mountain Lion (10.8)' started by Yeroon, Dec 15, 2012.

  1. Yeroon, Dec 15, 2012
    Last edited: Dec 16, 2012

    Yeroon macrumors member


    Jun 12, 2012
    I did something stupid. I pulled the plug out of my LaCie 2big 6 TB thunderbolt disk. As I'm currently using a 128 GB MacBook Air 2012 (which offer too little capacity), I moved my Home folder to the external drive. This worked pretty well for months.

    But then I suddenly pulled the plug of the LaCie when it was running and OS X froze (everything grey). This happened before and when I rebooted with the TB drive running, everything was fine again. But not this time.

    For some weird reason a blank account appeared after booting, with the default settings. My home folder was at /Volumes/3 TB RAID 1/Home-map/jeroen but nothing happened. It looked like the Mac had made folders named exactly the same as my external setup: '/Volumes/3 TB RAID 1/Home-map/jeroen'. I saw the folders when selecting it to change it to the original external location. When changing it to the external, nothing happened after reboot. Still a blank default desktop without any files (the files are still on the external). Changing the location of the home map didn't seem to have any effect.

    I then though the Mac got my home folder mixed up somehow, so I changed 'Home-map' to 'Home_map' on my external drive. After that I changed the location of the home map and pointed to this location. (/Volumes/3 TB RAID 1/Home_map/jeroen)

    But then I got an error while logging in. Just 'You currently can't login on account jeroen. An error occured so logging in is not possible' (translated, so it might nog be the exact words in English)

    And then changed it back tyo 'Home-map' but got the same message.

    So, I have all my account data, settings and programs (mail and such) on my external drive, but can't login. Luckily I do have a second user account with administrator rights (which I use when I use the MBA offsite).

    Does anybody have a clue about what to do next?

    I'm now considering to copy my external home map to my second user account, including all program data - but is this possible due to rights?

    Is there another option to restore my account?
  2. Yeroon thread starter macrumors member


    Jun 12, 2012
    Never mind, I found the solution after two hours of trying.

    On the Macintosh HD drive (SSD) was a folder named Volumes. It was hidden. It contained two versions of the LaCie Thunderbolt drive. I unmounted the drive, deleted the folders and mounted them again. Then I logged back in to my regular account (which was directed to the right location again) and it worked.

    Though I still wonder how I can copy a home map back to the internal drive again... I tried that and even though I changed the rights of several maps, I couldn't copy all user data due to restrictions...

Share This Page