Can't mount external hard drive in ML

Discussion in 'OS X Mountain Lion (10.8)' started by duggram, Sep 3, 2012.

  1. duggram macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #1
    I used my older MBP running 10.7.4 to repartition an external hard drive that I want to use for backups. No problem after repartition and it shows in Finder.

    Switch to newer MBP running 10.8.1. It can't mount the external hard drive.

    I've tried repairing and repartitioning in 10.8.1. Can't do either because the OS can't mount the drive.

    Any suggestion as to what I need to do to get this drive acknowledged by ML?
     
  2. desertman macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #2
    I would try to let Diskwarrior rebuild the directory of that drive. Diskwarrior can sometimes still work with drives that OS X does not recognize. In some cases you have to try and try again until Diskwarrior finally works with the drive (and in some cases also Diskwarrior does not work).
     
  3. duggram thread starter macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #3
    Took my MBP and external drive to the Genius bar. They used the hardware test device on it and declared that there is nothing wrong with the hardware. Tried my external on a copy of 10.8.0 that they booted my MBP into. It wouldn't work. That OS had the same issues my OS does.

    They concluded that it was a hardware problem with my laptop and would cost ~$800 to fix locally, $300 and a few weeks if sent out. Or, I could buy a new laptop.

    But they tested the hardware and declared it was fine.

    Did a clean install of ML last night with a new SSD. Runs fantastic. Tried both of my externals which use the same USB 3.0 case. They worked, for about 15 minutes and then the OS started having the same old problems. Can't mount, but if it does get it mounted after a reboot then I can't unmount it.

    Tried my old Maxtor backup external USB 2 drive. Works fine. Then I tried one of the USB 3 drives on my old MBP running Lion, works great. In fact TM is doing a back up now.

    I don't think my 2011 MBP needs to be rebuilt. I'd love to have a new MBP but it's hard to justify it when the problem does appear to be ML and USB 3 enclosures. Any other ideas?
     
  4. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #4
    There are ML and USB 3.0/external drive issues. Many are waiting for fixes for a number of issues like this...

    My external drives will not remount after sleep when using a USB 3.0 hub. The Hub is OSX compatible and does send the proper remount responses. ML just does not read them properly. Lion did.
     
  5. Hammie macrumors 65816

    Hammie

    Joined:
    Mar 17, 2009
    Location:
    Wash, DC Metro
    #5
    Is your external case by chance made by RocketFish? If so, they are not supported under ML... :(

    Apparently, Apple removed a driver in ML. However, the admins are not responding to any questions about what driver was removed by Apple so the users can ask that it be reinstated for a future ML update.

    I've considered trying to return it to BestBuy, but I feel that my efforts would be useless in this case. Especially since it has to be at least 6-8 months since I bought the enclosure.

    I ended up buying a StarTech.com USB2.0 enclosure for $20 in the mean time.
     
  6. duggram thread starter macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #6
    Yes. I have two of them. There's a reason RF doesn't make them any more. I got them off of Amazon for like $10.

    I have 3 extra laptop/SATA drives, one an SSD. I'll checkout StarTech.com. But I would like to go with a firewire or thunderbolt enclosure. In the mean time I have an old Maxtor backup external drive that I just cleaned up and will use for backups until something better comes along.

    Thanks for your post. Now I know what the problem is. Funny Apple just dropped the drivers for a product like that. Even though it's not in production any more, there's still some in use.
     

Share This Page