Can't mount external hd partition on mac only

Discussion in 'OS X Yosemite (10.10)' started by mrmaster, Feb 24, 2015.

  1. mrmaster macrumors newbie

    Joined:
    Feb 24, 2015
    #1
    Hi,

    I have a 1TB external Buffalo HD with 2 partitions. I use one partition for Time Machine backups, the other one for files.

    Today, I plugged in the HD and only one partition - the Time Machine one - showed up. I restarted my Macbook Air both with the HD connected as well as disconnected. I did that again on the other USB port. I ran Disk Utility (it didn't find anything); I booted into recovery mode ran disk utility there. I also ran fsck_hfs with the -dy, -fy, -drf options. I also tried to mount in readOnly mode with diskutil. No change.

    As a last step I decided to connect the HD to my Linux virtual machine.There, both partitions showed up just fine and with all my files. So it must be something that's Mac-specific. Can anyone help me get this back up running?

    Thanks!

    Mrmaster
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Probably best to show us screenshots of what Disk Utility and the System Report say they can see...
     
  3. mrmaster thread starter macrumors newbie

    Joined:
    Feb 24, 2015
    #3
    Thanks for the reply. Disk Utility couldn't find anything wrong with the partition. It was mounted read only in linux and it took forever to copy stuff off it, so I decided to install DiskWarrior. It fixed the problem within 5 minutes.... Well worth the money.

    thanks
     

Share This Page