Can't Mount External Mac OS SSD Since iTunes Update

Discussion in 'iMac' started by PJMCambs, Jun 6, 2019.

  1. PJMCambs macrumors newbie

    PJMCambs

    Joined:
    Jun 6, 2019
    #1
    Hi folks, new forum user here and what a great forum it is, I've been a long time reader. :)

    I have an issue with my main Mac OS boot drive, an external Samsung EVO 840 500GB in a thunderbolt case. It's been my boot drive for ages now and has been running perfectly, without any hitches, until last night.

    I did a simple iTunes update and when my iMac rebooted, it rebooted back to the internal 2TB HDD, which it has done several times before (I don't know why), but I simply change the Start Up Disk back to my SSD, but now it's not showing as available.

    I had approx 50GB of free space left on my SSD and was getting ready to archive some data, but after last nights update reboot, the drive shows as completely full in Disk Utility. There is no option to mount it and I think it's because it's full.

    I've spent most of last night and all day today trying many different ways to get some data removed from that drive, in the hope that it will allow me to mount it and clean up some space.

    I think the drive is okay, because it shows in Disk Utility, but does not have the eject symbol next to it.

    I've ejected it from Terminal and have read and tried 20 different things from Google and Youtube tutorials, but still stuck on it not mounting. I've tried both USB and Thunderbolt caddies on both Mac and Windows machine.

    Q: Why would a simple iTunes update fill the last 50GB of my drive.
    Q: Anyone know of any methods that would allow me to mount the drive to try and recover some space?

    Many thanks in advance, I'm really stuck.

    Cheers.
    Phill
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Some simple questions (because I'm simple-minded, of course!):

    1. Can you mount the Samsung external on the desktop (not boot from it, just mount it)?

    2. Once mounted, if you do a "get info" on the drive, how much free space does it have left?

    3. If it's still full, can you just "grab stuff on it", and move those things to the trash, and then empty the trash?

    4. If you can do #3, can you get the free space left on the drive up to about 20gb?
     
  3. PJMCambs thread starter macrumors newbie

    PJMCambs

    Joined:
    Jun 6, 2019
    #3
    Hi there, thank for a reply.

    No I can't mount it at all. In Disk Utility, it shows the drive, but without the eject icon, or the ability to mount it. I've tried several tutorials on how to mount it via Terminal, but still no luck.

    Screen Shot 2019-06-07 at 16.39.51.png
     
  4. mikey8811 macrumors member

    Joined:
    Mar 23, 2019
    #4
    I don't know if this is related but I had the same symptoms with external USB 3.0 HDD's. they would unmount themselves from Finder but still appear in Disk Utility. I wasn't able to eject them from Disk Utility nor from the diskutil function in Terminal.

    I attributed that to the USB standard not working well on Mac OS Mojave but now you seem to be facing a similar problem with a Thunderbolt connection.

    The Apple care people were unable to help.
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5

Share This Page

4 June 6, 2019