Cant mount network volume?

Discussion in 'macOS' started by trickyP, Mar 13, 2011.

  1. trickyP macrumors newbie

    Joined:
    Feb 26, 2011
    #1
    Hi all,

    using OS X, 10.6.6 on a mbp

    Im having some issues mounting a volume that is on a windows 7 network.

    I have (2) external HDD's connected to a windows 7 pc. One via eSata the other firewire. There are no passwords set. I am able to mount the firewire drive no problem, but I get a "Connection failed; You do not have permission to access the server" error when I try to mount the eSata volume.

    Both drives are set with the same permissions and are shared with the same preferences; and i'm trying to access them through finder -->connect to server

    Any help would be greatly appreciated - this is extremely frustrating.

    pk
     
  2. Riverside macrumors member

    Riverside

    Joined:
    Jan 5, 2008
    Location:
    Don't let the Macrumors level fool you.
    #2
    Good luck with this.

    Can you "see" the computer the drive is connected to in your Finder, under "Shared" in the sidebar?

    If so, you should be able to access the drive by clicking that computer's icon. If the drive is properly shared, it should show up in the list, but may or may not be read only.

    Windows and Mac don't network very well together on home networks.

    I have access to three different Windows computers from my Mac, and whether or not they even decide to show up in the finder is a crap shoot. I've never found a solution to the problem other than to wait until I can see them, then use them quick before they disappear again. :rolleyes:
     
  3. Riverside macrumors member

    Riverside

    Joined:
    Jan 5, 2008
    Location:
    Don't let the Macrumors level fool you.
    #3
    P.S. Is your Mac set up as part of the Windows workgroup? Check Apple > System Preferences > Network, then click Advanced > WINS. Make sure you have a NetBIOS NAME set up, and the appropriate Workgroup is selected in the dropdown list (should be the same as the workgroup your Windows computer is part of). I've also found it helpful to go to the router control panel (if you use one), and check the IP addresses of every computer connected to the router while they are on and connected, then enter every address in the WINS Servers list in the WINS control panel. Even if the addresses are dynamic (change every time the computers are connected), if you enter all of them, it seems as though the chances of the Mac connecting fair better. I have them all entered, so it doesn't matter whether they change, they're all more likely to connect this way.

    For example, the addresses used by my router are 192.168.2.2 (the router is 2.1) through 1.2.168.2.[whatever] ~ depends on how many computers you have connected to the network. If you have all the numbers entered, it won't matter how they are assigned by the router (since they are dynamic). The router always starts from 2.2, and goes up for each computer connected. If all the possibilities are entered, it appears from my set up they all tend to connect. At least, it's been more reliable than not having any of them entered.
     

Share This Page