Can't mount NTFS drives in OS X 10.6.7

Discussion in 'MacBook Pro' started by wilywampa, May 26, 2011.

  1. wilywampa macrumors member

    Joined:
    Sep 21, 2007
    #1
    I have an external hard drive connected by FireWire (or USB) and a Bootcamp partition. I can see both of them in Disk Utility, but I get the error "The disk “BOOTCAMP” could not be mounted." when I try mounting them. I have tried the Repair Disk option on the drives, and it works, but they still won't mount. I have tried using MacFUSE, Tuxera NTFS, NTFS-3G, and Paragon NTFS (installed and uninstalled one at a time) and had no success with any of them. This is extremely frustrating because I had no problems with this on my old MBP, but it just won't work on this Early 2011 MBP. Any ideas?
     
  2. wilywampa thread starter macrumors member

    Joined:
    Sep 21, 2007
    #2
    I also tried reformatting a small USB flash drive as NTFS in Disk Utility, and I can't even mount that in OS X.
     
  3. wilywampa thread starter macrumors member

    Joined:
    Sep 21, 2007
    #3
    I fixed it by removing /System/Library/Filesystems/ufsd.fs/

    What a waste of a night.
     
  4. JeMaTo macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    Thank you! you are amazing!
     
  5. Gabbelito macrumors newbie

    Joined:
    Jun 11, 2011
  6. wilywampa thread starter macrumors member

    Joined:
    Sep 21, 2007
    #6
    After solving the problem on my own, I found this webpage that suggests the same solution. It's in Paragon's Knowledge Base, not some random forum post, so I think you can trust it. I do know for a fact that that file does not come with OS X, so deleting it at least shouldn't cause problems.
     
  7. Seagee48 macrumors newbie

    Joined:
    Aug 7, 2011
    #7
    Thanks !!

    Thank you so much for posting this solution.

    Worked like a charm !!

    Cheers
     
  8. bowjol macrumors newbie

    Joined:
    Nov 7, 2011
    #8
    This is THE REAL SOLUTION.

    I can see the disk using disk utility but I can't mount it. Try repair disk and verify disk with no luck. In my iMac I already installed PARAGON and NTFS 3G but the disk still can't mount.

    This simple solution, really works.:)
     
  9. deepakvrao macrumors regular

    Joined:
    Oct 16, 2011
    Location:
    India
    #9
    Just can't find this file and I see others also seem to have the similar issues. Any suggestions?
     
  10. mekkab macrumors newbie

    Joined:
    Feb 22, 2012
    #10
    this worked for a FAT volume

    I have a 16gb usb stick that was FAT formatted. su'd, cd'd to /System/Library/Filesystems, 'rm -rf exfat.fs' and now disk utility can unmount and reformat the drive.
     
  11. pia12254 macrumors newbie

    Joined:
    Jun 23, 2010
    #11
    I was also having similar issues and didn't have that file referenced above.

    My solution ended up being a combination of a couple of things. First, my NTFS drive would mount, but I couldn't write to it, files wouldn't show up, etc.

    I finally realized I had an older version of the NTFS plugin. I forgot that I had upgraded my system to Lion since buying the plugin. After I upgraded from Ver. 7 to Ver. 9.5 of the plugin the drive wouldn't show up on the Desktop or in the plugin interface.

    However, it did show up in Disk Utility, so I did the Verify/Repair disk and there were some issues. After it went through and did its thing the drive started mounting and I can now read/write to it as before.

    Hope this helps!
     

Share This Page