Can't mount SDXC card, NTFS format

Discussion in 'Mac Basics and Help' started by mman824, Aug 24, 2012.

  1. mman824 macrumors newbie

    Joined:
    Aug 24, 2012
    #1
    I have a MacBook pro 5.1 (unibody, late 2008) running OS X 10.5.8
    I recently got a canon G1X camera and 64gb SDXC card from SanDisk. I just put the card in the camera and started taking pictures. Now I have 1,600 some pics on the card in raw and .jpeg, which is probably around 40 gb, and I can't get the pictures off the card. I can't connect the camera to my computer via USB because it says 'communication error', which according to the manual means that I have over 1,000 pictures on the card so it won't work. I tried an SD card reader and it said I couldn't mount the drive. DiskUtility told me it was formatted in NTFS, so I tried on a windows machine running Vista and it said I needed to format the drive before it could be read. Then I got Tuxera NTFS, still won't mount the disk. Now it lets me run 'verify disk' though, here's what I got.
    Verifying volume “disk1s1”
    ntfsck 3011.12.9-mac
    NTFS signature is missing.
    Couldn't open volume '/dev/disk1s1'!
    Checking NTFS Superblock ...
    Correcting errors...
    NTFS signature is missing.
    Failed to startup volume: Invalid argument
    NTFS signature is missing.
    Trying the alternate boot sector
    NTFS signature is missing.
    Unrecoverable error
    Volume is corrupt. You should run chkdsk.
    ERROR(22): Opening '/dev/disk1s1' as NTFS failed: Invalid argument
    The device '/dev/disk1s1' doesn't have a valid NTFS.
    Maybe you selected the wrong partition? Or the whole disk instead of a
    partition (e.g. /dev/hda, not /dev/hda1)? This error might also occur
    if the disk was incorrectly repartitioned.
    Error: Filesystem verify or repair failed.

    I can look at the pictures on the camera, and on other Canon cameras (haven't tried other brands). I know that my pictures are there and the card works, but I don't know if it's actually NTFS or how to get my pictures off the card. Any help would be great.
     
  2. mman824 thread starter macrumors newbie

    Joined:
    Aug 24, 2012
    #2
    Alright, well I've figured out my very simple problem...and since I can't delete this thread I'll share. SDXC cards come in the exFAT format (not NTFS like I had thought), which OS X 10.5.8 can't read/write. I've since upgraded my OS, and voila- pictures.
     

Share This Page