Can't move a large file

Discussion in 'macOS' started by BiggAW, Oct 11, 2011.

  1. BiggAW macrumors 68020

    Joined:
    Jun 19, 2010
    Location:
    Connecticut
    #1
    I posted this in the Windows on the Mac forums, but I realized that it's really an OSX issues, not a Windows issue. I'm trying to move a 40GB VM from my HDD to my SSD (HDD in regular spot, SSD in Optibay), and "Can't copy [filename] because there isn't enough free space". There is about 90GB free, and the VM is 40GB. The SSD is my boot drive.
     
  2. firestarter, Oct 11, 2011
    Last edited: Oct 11, 2011

    firestarter macrumors 603

    firestarter

    Joined:
    Dec 31, 2002
    Location:
    Green and pleasant land
    #2
    Have you emptied your trash?

    Could be some old big files still stored in your trash can. Empty trash to free the space.
     
  3. BiggAW thread starter macrumors 68020

    Joined:
    Jun 19, 2010
    Location:
    Connecticut
    #3
    Yup, rebooted as well. Didn't help.
     
  4. firestarter macrumors 603

    firestarter

    Joined:
    Dec 31, 2002
    Location:
    Green and pleasant land
    #4
    Interesting.

    Do you have an open sparse disk image that's located on your SDD and has lots of free space in it? (I've noticed that sometimes the OS seems to 'reserve' disk space for images).

    What is your VM from? Have you tried going into VMWare/Parallels and compacting the image down?
     
  5. BiggAW thread starter macrumors 68020

    Joined:
    Jun 19, 2010
    Location:
    Connecticut
    #5
    I don't have any disk images mounted if that's what you're asking. It was recently compacted, so there's not much more space to get rid of. Interestingly enough my Win7 one, which is like 15GB, can move back and forth just fine. The XP one is a monster because it's got office, Matlab, Solidworks, Roller Coaster Tycoon, and a bunch of other crap on it.

    ----------

    I'm up to 98GB free, and it still won't copy.
     
  6. BiggAW thread starter macrumors 68020

    Joined:
    Jun 19, 2010
    Location:
    Connecticut
    #6
    I tried compacting the disk with iDefrag (I know defragging an SSD is bad), and that didn't help. There's something majorly wrong here. The disk has 111GB out of 160GB free, but yet it looks 3/4 full in iDefrag. I'm not sure if it's at the OS level, or at the TRIM/GC level. I don't really have time for it this week, but I may have to nuke the disk and re-install from scratch. :( I'd really like to figure out how to fix this without resorting to those extreme measures, however.
     
  7. BiggAW, Oct 11, 2011
    Last edited: Oct 11, 2011

    BiggAW thread starter macrumors 68020

    Joined:
    Jun 19, 2010
    Location:
    Connecticut
    #7
    It looks like it's copying now! Maybe GC ran on the drive, and now there's a big enough bock of space? Well, whatever it is, I'm happy. I still would like to know what's causing this issue, however, as it is a bit perplexing...

    EDIT: It's copied. Now copying the other (smaller ones) back over. Go figure.
     

Share This Page