Can't move items in Finder, other Finder issues

Discussion in 'OS X Yosemite (10.10)' started by dcslacker, Feb 3, 2017.

  1. dcslacker macrumors member

    Joined:
    Apr 23, 2004
    #1
    The Finder is not working like it used to. For example, when I want to move items to different folders, nothing happens. I have to do a force quit of Finder from the Activity Monitor or a restart for the Finder to work properly.

    There was a thread suggesting creating a new user account and seeing if you could do actions there without issue. I did this and was able to move items without problem.

    https://forums.macrumors.com/threads/finder-not-responding.1909489/

    So I think it's user files that are making Finder act strange. I don't know what files could be affected or how to troubleshoot this.

    I tried a clean install of Yosemite 10.10.5 but that didn't resolve issue. Tried deleting plist but that didn't work either.

    I have a 2012 MBP with Samsung 850 SSD.

    Really needing help on this. I don't want to erase everything and reinstall all my apps and files, especially if I'm just going to reinstall the file(s) that made Finder act all strange.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    So that pretty much proves it is some startup or launch item that is running in the main user account and not the test account. Download and run the app Etrecheck and it will create an anonymized report showing all startup or launch items. You can post the report here for us to have a look. Do this from your main account.
     
  3. dcslacker, Feb 3, 2017
    Last edited: Feb 3, 2017

    dcslacker thread starter macrumors member

    Joined:
    Apr 23, 2004
    #3
    Untitled4.jpg Untitled3.jpg Untitled1.jpeg Untitled2.jpeg Untitled3.jpg Untitled1.jpeg Untitled2.jpeg
    Thank you for recommending Etrecheck, Weaselboy. I ran it and found these things in red (though they show up as gray colored in the screen grabs).

    The adware surprised me, but they're all rather old so I don't think they're the culprit.
    I'll delete the stuff that's out of date/not compatible anymore.
    I don't know what the "configuration files" thing is, but it was red and I don't know how to fix that.

    In "Launch Daemons" there's a failed plist postgresql that looks suspicious. If that's the bug, then how would I fix that? Just delete and restart?

    I'll delete the stuff that's not working and see if Finder improves.
     
  4. dcslacker thread starter macrumors member

    Joined:
    Apr 23, 2004
    #4
    UPDATE: I deleted everything that was failed or was not compatible. Finder seems to be working better, but still can't do a simple thing like move a file from the desktop to a folder in Documents. I guess I'll have to work with this for now until some other solution can be found.
     
  5. Weaselboy, Feb 4, 2017
    Last edited: Feb 4, 2017

    Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    The fact that it works okay in another account means the issue is in one of the user launch sections and not the main launch section, so focus there.

    I would go to /Library/StartupItems and remove everything there, as that startup method is no longer supported.

    Then start removing things from ~/Library/LaunchAgents (~ is your users folder).

    Yes, you can just delete the launch daemon from /Library/LaunchDaemons.

    There is a section of the Etrecheck report you did not post that shows everything in the login items section of your user name in Users & Groups in System Preferences. That would be a prime spot also since it only impacts the one user account.

    You also might want to run MalwareBytes to check for adware/malware since you did find one already.
     
  6. dcslacker thread starter macrumors member

    Joined:
    Apr 23, 2004
    #6
    Well, I've done all the things you listed and Finder seems to improve some but still not able to move a file to a folder. Finder preferences window is all grayed out.

    The user login items are few: Dropbox, iTunes, Box, and Caffeine. When I run Etrecheck now nothing is in red and all seems to be clear in the sense that they're blue or green colored.

    The test user account does work perfectly fine, so it has to be something in my user account! I'm not sure how to troubleshoot now. Is is possible that it's something in a hidden folder under my user account?

    I'm going to try to run Etrecheck on the test user account and compare with what's on my account???

    1Untitled.jpg 2Untitled 2.jpeg 3Untitled.jpg
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Just as a test try removing Box and Dropbox from that user login. Those both have Finder integration and I'm wondering if having them both running together is causing a conflict.

    Also go to to that users launch agents folder I gave you earlier and remove everything and reboot just as a test.

    Finally, run this command in Terminal the reboot immediately after. That will reset Finder's preferences.

    Code:
    rm ~/Library/Preferences/com.apple.finder.plist
     
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    I would also suggest that you may still have some adware.
    Download and run MalwareBytes. That should find anything else that is part of your "internet shopping experience". :D
     
  9. dcslacker thread starter macrumors member

    Joined:
    Apr 23, 2004
    #9
    YES!!! I removed all the stuff related to Box from the System Preferences and other places Box has files (I referred to the Box website on what files to remove).

    Right now Finder seems to be working again!!!

    Thank you so much for your help, Weaselboy!!!

    In case Finder starts acting up again I will try these other steps!

    My weekend got a lot better LOL. :apple:
    --- Post Merged, Feb 4, 2017 ---
    Thank you for suggesting the app. Weaselboy also suggested this and I did download and run it and things seem to be okay.

    Your confirmation of the app suggestion just means that's what I needed, because I have been looking for a malware app! :cool:

    So thankful for the Macrumors community!!!:apple::apple::apple:
     

Share This Page