Can't navigate 'backwards'

Discussion in 'iMac' started by (L)SD, Oct 7, 2013.

  1. (L)SD macrumors newbie

    Joined:
    Dec 17, 2010
    Location:
    Texas
    #1
    Quite frequently, the 'back' button, (the little triangle in upper left corner) won't let me 'go back'. For instance, if I'm checking my email, and click on a link someone sent me, I can't go back to my inbox, I have to use 'History' to get back to my main inbox. It also happens when i'm on a website which has a link to another website. Is this normal? (Lion 10.7.2). It doesn't happen in windows (XP or 7). Also, is there a name for those 2 little triangles? Thanks.
     
  2. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #2
    On some browsers, some websites have code that "traps" you from hitting the back button. This is intentional based on the web site creator. You will either have to hold down the back button and click on your Inbox from the history that appears, or open links from your friends in a new window. You can either right-click the link and open in a new window (or tab), or press Command+Option when clicking the link.

    If none of this works to your satisfaction, consider trying another browser. There are plenty to choose from, and one of them may do exactly what you're expecting it to.
     
  3. (L)SD thread starter macrumors newbie

    Joined:
    Dec 17, 2010
    Location:
    Texas
  4. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #4
    Sounds to me like it's just opening a second tab or second window from your links, you can change it to links opening in current tab if you want to go back and forth.
     

Share This Page