Can't open Accounts pane in System Prefs

Discussion in 'macOS' started by oquela, May 4, 2011.

  1. oquela, May 4, 2011
    Last edited: May 4, 2011

    oquela macrumors newbie

    Joined:
    Apr 9, 2009
    #1
    I've been having this issue for over a week. I just noticed it, since I had to take my MBP (LAte 2008 2.4 MHZ unibody, 4gb) in to the Apple Store for a repair, and wanted to remove any passwords so the tech wouldn't have any problems working on it.

    I couldn't access the Accounts pane. It freezes for a bit, then the entire window closes, giving me the option to ignore or tell Apple about it.

    I had to remove the password from the Snow Leopard disk. I was told to remove the prefs file, the plist file, and cache files; nothing worked. I was told to reinstall a clean system. That didn't work, either. I upgraded using the combo updater to 10.6.7. Still no go.
    It even happened in front of the Genius at the Apple Store. He suggested removing the prefs, which I had already done, then recommended I do the clean install, which I later did (but wasn't effective.) I would hate to have to delete everything.

    Does anyone have any suggestions?

    I know that Apple had an issue w/an Accounts bug in Snow Leopard that deleted user info. Can this be related somehow?
     
  2. oquela thread starter macrumors newbie

    Joined:
    Apr 9, 2009
    #2
    Found the solution:

    http://lockergnome.net/questions/27875/why-is-my-accounts-preference-pane-crashing



    it suggested I use Terminal. Now granted, I am a complete noob with terminal, and especially Sudo command, as I’ve heard it can cause havoc on your machine, but seeing as I’ve scoured the internet and have tried EVERYTHING else, including a fresh OS install and update, I figured this couldn’t hurt too much. I checked the Users folder and found I had an extra “Guest” folder called Guest1.

    I typed in the following in Terminal:

    sudo dscl . -delete /users/Guest1 (please check formatting BEFORE cutting/pasting, as I'm not an expert in Terminal)

    and then tried the Accounts pane. It worked. Try at your own risk. Hope this helps someone!
     

Share This Page