Can't open any 3rd party apps - URGENT!

Discussion in 'iPhone' started by badlydrawnboy, Aug 7, 2010.

  1. badlydrawnboy macrumors 65816

    Joined:
    Oct 20, 2003
    #1
    I've been an iPhone owner since the first model (I have iPhone 4 now), and I've never seen anything like this.

    Last night my iPhone ran out of charge. This morning, when I plugged it in it had to charge for a few minutes before it would turn on. Once it turned on, it said "waiting for activation: this may take a while". I thought this was strange, because my phone is already activated. I'm in an area with no reception, though, so maybe that was the issue.

    Once the phone turned on, I tried to open some of my apps. But none of the 3rd party apps would open! When I tap them they appear to open but they shut down / crash right away. Strangely, however, all of the Apple apps that come with the phone will open without a problem (Maps, Mail, Safari, iCal, etc.).

    I tried a hard reset but that didn't help. I'm away from home so I can't do an erase and store, and I really need access to some of the data in those apps.

    Any ideas?
     
  2. Rajani Isa macrumors 65816

    Rajani Isa

    Joined:
    Jun 8, 2010
    #2
    If you can, try installing a new (free) app from the app store. I've had 3rd party apps do the same kind of instant crash behavior you describe, and resyncing with iTunes always fixed it - and several times I was able to fix it via downloading an app (which required my iTunes login info, of course. This seems to be what the phone needs).
     
  3. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #3
    I had the exact same problem. My 3GS said that it wasn't activated for no apparent reason but plugging into iTunes fixed it. Afterwards 3rd party apps would not open. Installing an update to an app fixed it and as the previous poster said I expect installing a new app would have the same effect.
     
  4. badlydrawnboy thread starter macrumors 65816

    Joined:
    Oct 20, 2003
    #4
    I updated apps and downloaded a free one. That worked for some apps, but five of them still wont open. Unfortunately, one of those has the data I urgently need, and I'm away from home so I can't just delete the app and re-sync. I guess I'm just out of luck.
     
  5. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #5
    You did try resetting the phone yes?

    You can always delete and re-download from the app store for free.
     
  6. badlydrawnboy thread starter macrumors 65816

    Joined:
    Oct 20, 2003
    #6
    Yep, but then I lose the data stored by that app - which is the only reason I need to open it.
     

Share This Page