Can't open CD drive, tried normal methods.

Discussion in 'Mac Pro' started by macuser2010, Apr 27, 2009.

  1. macuser2010 macrumors newbie

    Joined:
    Apr 27, 2009
    #1
    A Mac Pro booted to the flashing question mark folder after the hard drive started making unnatural noises. I replaced the drive. When I boot, now, it briefly shows a black screen, then makes the Apple chime noise, shows a gray screen, pauses for some time, then shows the flashing question mark folder. I want to eject the optical drive so I can boot leopard and install on the new hard disk. There should not currently be a disc in the drive.

    I have tried holding down the eject key at the flashing question mark screen, tried booting while holding Option, booting holding Cmd+Option+O+F, and holding the mouse button. It just continues the aforementioned routine and goes to the blinking question mark folder.

    I understand that if I could get to open firmware I could easily eject the drive, but I cannot get there. Maybe I'm not holding the key combinations at the correct time? I've tried before, during, and after the chime, and just holding them before even pressing the power button. I also tried booting without the apple keyboard/mouse to make sure a stuck button wasn't the problem.
     
  2. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #2
    Open the hatch with your finger, there you can see a small hole to the left under the tray. Stick a paper clip in there.
     
  3. zmttoxics macrumors 65816

    zmttoxics

    Joined:
    May 20, 2008
    #3
    The CMD+OPT+O+F does not work on Intel macs. This was the command to boot into OpenFirmware which is replaced by EFI on Intel macs.

    The correct command to open the drive is to hold down the mouse button when hitting the power switch. You can also try the physical button on the drive as well as the above mentioned paper clip method (do this last).
     
  4. macuser2010 thread starter macrumors newbie

    Joined:
    Apr 27, 2009
    #4
    Thanks for clarifying about the open firmware. The mouse button method wasn't working either, though. However, I was able to slide the drive door down, as Cindori suggested (something which I was afraid to force before getting the suggestion), and while there was no hole visible, I could shove a paper clip down in there and press the manual eject button. Thanks.
     

Share This Page