Can't open pdfs in Safari 4

Discussion in 'Mac Apps and Mac App Store' started by benlee, Feb 28, 2009.

  1. benlee macrumors 65816

    benlee

    Joined:
    Mar 4, 2007
    #1
    PDFs will not load in Safari 4. I just get the spinning load symbol and nothing happens.

    Anyone else have this problem.
     
  2. The-Mac-Maestro macrumors newbie

    The-Mac-Maestro

    Joined:
    Feb 28, 2009
    Location:
    Australia
    #2
    I have just tried to open an iAntiVirus pdf file in safari and it took around 5 seconds to load and it worked... Maybe you should download Adobe Reader or maybe a special plugin just to read your .pdf . Are you sure in the safari preferences safari is the default browser to open .pdf ? If none of this works i suggest to do the following : On the top right of your safari browser there is a bug !! Click and fill in the requirements and maybe take a screenshot of the turning circle (Cmd+Shift+4) and there send it to apple and maybe they will correct this error !! :apple:
     
  3. All5Horizons macrumors newbie

    Joined:
    Apr 15, 2009
    #3
    I've had the same problem since installing Safari 4.0 on my MacBook. I've scoured all of the preference settings but can't find anything to make it work.

    Anyone have any other suggestions?
     
  4. benlee thread starter macrumors 65816

    benlee

    Joined:
    Mar 4, 2007
    #4
    I can't exactly remember what I did to fix the problem. But I do remember it had to do with preferences in a recently installed adobe acrobat. There was a preference that I changed in either acrobat or safari that fixed the problem.
     
  5. staccato83 macrumors 6502a

    staccato83

    Joined:
    Sep 9, 2008
    Location:
    Las Vegas
    #5
    I had Adobe reader installed and I couldn't open PDFs in Safari at all. I found this fix though... (credit goes to J@ffa)

    Go to Macintosh HD>Library>Internet Plugins and delete AdobePDFViewer.plugin and then quit Safari.

    Now Safari 4 will use Preview to open the PDFs.
     
  6. sho38 macrumors newbie

    Joined:
    Jun 7, 2007
    #6
    Deleting the PDFviewer plugin..works for me! Thank you!
     
  7. LastZion macrumors 6502a

    Joined:
    Apr 13, 2006
    #7
    Deleted the file, now it loads in Dreamweaver as a PHP file...
    Help please
     
  8. Morod macrumors 68000

    Morod

    Joined:
    Jan 1, 2008
    Location:
    On The Nickel, over there....
    #8
  9. dagnome macrumors newbie

    Joined:
    Jul 22, 2009
    #9
    If you launch Adobe Reader (9), and check the Internet Preferences, there is a checkbox for "Open PDF in Browser using"... and a popup that shows any usable Adobe Apps installed on that machine.

    UNCHECK that, Apply it, quit Safari and relaunch - bang - problem solved!
    Safari now uses its internal PDF rendering.
     
  10. iGary Guest

    iGary

    Joined:
    May 26, 2004
    Location:
    Randy's House
    #10
    Thanks, this solved my problem.
     
  11. arepadetrigo macrumors member

    arepadetrigo

    Joined:
    Oct 6, 2005
    #11
    Thanks

    My wife's Mac had the Adobe plugin and I deleted it from the Internet Plugins folder in the Library and it worked! I just wanted to thank you guys on behalf of my wife for taking the time to post that solution! :D
     
  12. muffinru macrumors newbie

    Joined:
    Jul 23, 2007
    #12
    Hello all.

    I am having the same problem. I tried deleting the Adobe internet plug-in, and have also tried resetting the Adobe internet settings as described above. I've restarted Safari, even tried restarting the comp, and no luck. I've even uninstalled Adobe Reader at this point and still can't get my pdf-s to open in Safari. I know that this is a problem due to Adobe reader 9 because I had no issue until I recently installed Adobe Reader. Any other ideas??

    Edit:
    I've also tried reinstalling Safari, but no luck. Seems that the comp remembers all my settings anyway.
     
  13. arkansasamy macrumors newbie

    Joined:
    Apr 19, 2010
    #13
    I had the same issues. This may be too simple to be true for you, and I can't believe I missed it. I was trying to down load some 'smart pdf' files that were actually tax forms. I downloaded the latest version of Adobe Reader, but when I clicked on the form, I got a message telling me to visit adobe website to get the latest version. I then noticed something at the bottom of the page that has an arrow to the left, and arrow to the right and a camera icon. I clicked on the camera icon and the pdf opened in another window. So relieved now.
     
  14. LastZion macrumors 6502a

    Joined:
    Apr 13, 2006
    #14
    Not sure if you still need help here, but i solved it by running Safari in 32 bit mode, all good now.
     
  15. ld0yle macrumors newbie

    Joined:
    Dec 14, 2009
    #15
    Thanks LastZion

    I had no "adobepdfviewer" to delete so I took the advice of LastZion, above, and at least got a big icon in the Safari window so I knew I had done something right. I had dicked around with the PDF Browser Plugin "get info" window, changing the "open with" from Default Folder to Safari. After switching that back to Default Folder, which it seems to want, I was fine. Apple is getting counter-intuitiver and counter-intuitiver.
     
  16. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #17
    You DO know this thread was started a year and a half ago, right? Before Safari 5 was released.
     
  17. xi mezmerize ix macrumors 6502a

    xi mezmerize ix

    Joined:
    May 24, 2010
    Location:
    Maryland, USA
    #18
    Oh sorry I didn't even look at the date I just read the posts haha.
     

Share This Page