Can't open Photoshop Elements anymore. Help!!

Discussion in 'Design and Graphics' started by silverspike, Feb 15, 2012.

  1. silverspike macrumors newbie

    Feb 15, 2012
    I don't know If any of you smart people can help me out.

    Recently I downloaded some file joining programs onto my antiquated old Mac only to discover that one of the programs I downloaded has managed to bugger my machine right up.

    For some weird reason it turned my Photoshop elements icon in my tool bar into some weird file that was connected to one of these file joining pieces of software that I'd downloaded, which meant every time I tried clicking on it it wouldn't open and wouldn't recognize It as being Photoshop at all.

    Stupidly I panicked and binned all those file joining programs that had been on my desktop plus that corrupted Adobe icon into the bin and flushed it, and now I can't start up Elements anymore. Even though I can still see that I have an Adobe Elements folder in Applications It just won't open and my machine doesn't even seen to recognize it's there.

    As my old Mac is so old and broken (It's still stuck on running 10.4) it won't accept discs anymore so I can't even reinstall the original software. I have another even older 15 inch Mac which still works and which has Elements installed, but I have no means in which to get it across to the other one. Is there anyway of re installing Elements without a disc, or (as I'm suspecting) it the original restart disc or nothing?

    When I double click on any old adobe photoshop file it will start the program up, but I can't drag any new images into it at all. It's like the machine is no-longer recognising it's on there anymore.

  2. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    What was the program and where did you get it?
  3. silverspike thread starter macrumors newbie

    Feb 15, 2012
    The two I tried out were HJsplit and MacHacha. God only knows what I did wrong. I didn't even touch then with photoshop.
  4. ObuckiO macrumors regular

    Dec 9, 2011
    Hi MacRumors folks.
    Sorry newest(older) thread i could find to post on what was close to my problem. Anyhow, PhotoShop elements 8 came with my Bamboo tablet installation disc's.. that i cannot find. My Bamboo app. works fine and all else, after i (for a ad blocking idea:confused:), uninstalled Adobe Flash on Late 08' MacBook Pro, running Lion, (everything seems to be up to date and runs great), Although, After finding out not all Youtube vids would play, I installed the newest Adobe Flash(as offical mentioned links from MR's), and fixed that youtube issue. Now.. that i have tried to open Photoshop Elements this pop's up..
    Screen Shot 2012-07-16 at 10.03.18 PM.png
    So, Bottom line: Do i have to "Manually remove Application" as GGJ Studios recommends(which i've used before, Thank's GGJ.), of Photoshop element's large program to get it working again w/wo Discs, or is there anything else that's in these files that don't take discs?
    BTW:I've looked for hours for installation CD, and might still get lucky with hunt if that is the only answer, just.. i think that disc had no name to help with describing which one was which.
    Thanks for any help:)

Share This Page