Can't open preferences in iCal

Discussion in 'Mac Apps and Mac App Store' started by Atrog, May 18, 2011.

  1. Atrog macrumors newbie

    Joined:
    May 18, 2011
    #1
    Hey everyone,
    Forum newbie here, so hi!

    The problem I'm having is that iCal will open, but I can't open iCal preferences, or create any new events. Basically it will open but won't actually let me do anything.

    I googled my problem and found a few suggestions.
    First I tried deleting the com.apple.iCal files from the ~library/preferences folder. Nothing.

    Next, I tried to uninstall and then re-install using the osx disc, but unfortunately no luck.

    Then, I tried using the program Pacifist to re-install iCal, but still nothing.

    I usually have iCal synced with my google calendar and I seriously use it everyday so this is driving me crazy. :confused:

    Also, unfortunately in a moment of bad judgement I deleted all of my back ups off my external hard drive to free up space. I thought I left the most recent one, but apparently not...so using time machine to do a restore isn't an option.

    Does anyone have any other advice?

    Please and thank you. :)
     
  2. Atrog thread starter macrumors newbie

    Joined:
    May 18, 2011
    #2
    Problem solved! Hopefully it will help if someone else has the same problem.

    Thanks to more googling I found a thread on the apple forums. I had tried deleting the ~library/preferences folders, but had not deleted all of the cache files from the ~library/calendars folder.
     
  3. davidkrocks macrumors newbie

    Joined:
    Apr 27, 2011
    #3
    hey, You helped me solve the same problem! Thank you for posing the answer afterwards!:eek::cool:
     

Share This Page