Can't open Safari

Discussion in 'OS X Yosemite (10.10)' started by MoodyM, Dec 16, 2014.

  1. MoodyM macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #1
    This has happened all of a sudden - was working fine last night, put MBP to sleep, tried today, Safari crashes on open with:

    http://pastebin.com/w1NJCG0S

    OS X 10.10.1, 2013 rMBP

    Thanks
     
  2. MoodyM thread starter macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #2
    I just tried Repair Disk Permissions then restarted, didn't work.

    I then booted Mac into Safe Boot, and logged on as me. Safari opened fine, so I disabled all my extensions, rebooted Mac normally - same crash/error in Safari as before

    ----------

    Also should add it crashes with the same error under a different user account.

    ----------

    Tried resetting PRAM/NVRAM, no luck

    ----------

    I've also tried removing everything from Library\Internet Plug-ins and ~\Library\Internet Plug-ins (which was empty anyway), no luck.

    I also deleted ~\Library\Preferences\com.apple.Safari.plist, still no luck
     
  3. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #3
    You may try to go to ~\Library\, rename the "Safari" folder to "Safari_BAK", and then start Safari.

    Of course, I suggest you only do this after you have proper backup. Otherwise, you may loss all your history, bookmark, extension...

    If Safari can start successfully, but like back to factory setting. Then you may try to recovery your data from that "Safari_BAK" folder to the new "Safari" folder.

    It if does nothing. You can simply remove the new "Safari" folder, and rename the BAK folder back to Safari.
     

Share This Page