Can't open spotlight folder "aliases" after Snow Leopard upgrade

Discussion in 'macOS' started by khunsanook, Mar 18, 2010.

  1. khunsanook macrumors 6502

    khunsanook

    Joined:
    Jul 2, 2006
    Location:
    East Asia
    #1
    Hi all,

    I'm dealing with a crazy annoyance after upgrading to Snow Leopard - currently running 10.6.2

    I have 2 duplicate, external, 1TB WestDig Drives. I have no problems accessing files from the Finder, but if I use Spotlight search or Smart Folders, the corresponding folders on the external drives never open on the first try. I always receive the message:

    The alias “…” can’t be opened because the original item can’t be found.

    On the second try the folder opens fine.

    It seems that after my Snow Leopard upgrade every spotlight search on the external drive reveals "missing" folder aliases although the "aliases" appear as regular folder icons.

    I tried re-indexing spotlight but this did not solve the problem.

    External Drive volume in terminal:
    Code:
    drwxrwxr-x  21    782 Mar 14 17:18 PHOTOGRAPHY ARCHIVE
    FWIW I've found others having similar problems on the Apple forums HERE and HERE. I've tried their suggested PathFinder workaround without success. Also noticed a MacRumors member with a similar problem.

    This is driving me bonkers because it renders Smart Folders somewhat useless. Additionally, these external drives work fine on my old installation of 10.5 Leopard

    Thanks for any help!
     
  2. niewiesznic macrumors regular

    niewiesznic

    Joined:
    Oct 25, 2009
    Location:
    Internet
    #2
    Hello,
    I have the same problem with USB connected LACIE drive (WD drive inside).
    I get the same exactly info:
    "The alias “…” can’t be opened because the original item can’t be found."
    I have 10.6.3 and cannot access it with finder, or do anything with it. I can access it with, however with ForkLift.
    What the hell is APPLE doing ?
    Why I can't access my files ??????????
    Anyone knows the answer ?

    Take care,

    P.
     
  3. tmdowd macrumors newbie

    Joined:
    May 28, 2010
    #3
    Same Isse Here...

    Just got the Macbook Pro and it mounts the external drive but I get the same 'alias' response... I thought I picked up a bug when I migrated some files, so I erased the hard drive and started fresh... then tried all the things I read on posts here and on the other forums. Everything works fine on the old laptop with 10.5.... It's definitely a Snow Leopard issue.
     

Share This Page