Can't open VLC?

Discussion in 'Mac Basics and Help' started by Akele, Oct 21, 2012.

  1. Akele
    Expand Collapse
    macrumors newbie

    Joined:
    Jul 16, 2011
    #1
    Hey guys, since upgrading to Mountain Lion, I realised that I can no longer use VLC. What happens is, as soon as I open it, a "space opens up in the dock" for half a second to hold the application icon, but then instantly retracts and nothing happens afterwards. Anyone know what's up? This actually happened to some other applications as well and I don't know why!
     
  2. simsaladimbamba
    Expand Collapse
    Guest

    simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Do you use the latest version of VLC Player?
    Have you checked, that the other problematic applications are compatible with OS X 10.8 Mountain Lion?
     
  3. Macman45
    Expand Collapse
    macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    I had to download the latest (64 bit) version from sound forge...The old one didn't work on any of my Macs.
     
  4. Weaselboy
    Expand Collapse
    Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Look inside the VLC installer DMG and in a folder there there is a script that will delete your VLC pref settings. Run that script then try to launch VLC again.

    If it still just sits there, try a right click on the VLC icon on the dock then select open. You will see a message that this app was downloaded from an unknown source on the Internet (I can't recall the warning exactly). Just say it is okay in that dialogue box to run the app. I think what you are seeing is Mountain Lions sandboxing that prevents non-Apple Store apps from launching without your explicit approval. You can bypass this setting in the General tab of the Security & Privacy pane in System Preferences. Just set it to Anywhere if you want to allow all apps to install without going through the right click business I described.

    For better security you may want to leave this setting alone though and just do the right click deal.

    [​IMG]
     

Share This Page