Can't paste files with Lion (Finder)

Discussion in 'Mac OS X Lion (10.7)' started by Clancycoop, Jul 25, 2011.

  1. Clancycoop macrumors member

    Joined:
    Nov 8, 2007
    #1
    Please excuse me if this has already been addressed, I tried searching but didn't see anything about this.

    When in finder I may highlight a file, press cmmd+C or use the edit menu to copy a file, and then attempt to paste it somewhere using cmmd+V or edit menu.

    The file seems to be copying, there is a status bar if the file is large, but upon completion the file's name disappears from the folder to which I am copying it.

    I asked my friends who have upgraded and they haven't experienced this.

    I have checked for updates, and tried copying various file types. I can drag files to a new location, but sometimes I want to duplicate them (especially photos).
     
  2. maccauni, Jul 25, 2011
    Last edited: Jul 25, 2011

    maccauni macrumors member

    Joined:
    Jan 28, 2009
    #2
    I've got the exact same problem. I read on the apple forums that if you copy the file in terminal it will work but not any other way. :mad:

    I've not come across a fix as of yet.

    Anyone?

    EDIT: FIXED

    if you relaunch Finder using the terminal it fixes this problem.

    copy this into terminal to relaunch finder:
    killall Finder && open /System/Library/CoreServices/Finder.app
     
  3. Clancycoop thread starter macrumors member

    Joined:
    Nov 8, 2007
    #3
    That fixed it

    This worked for me. Thank you very much.
     
  4. Marcus Cyganiak macrumors newbie

    Joined:
    Jul 4, 2010
    Location:
    Vancouver, BC, Canada
    #4
    This worked for me as well; however, the problem is back the next day...
     
  5. franmatt80 macrumors 6502a

    Joined:
    Jan 11, 2010
    #5
    Can't offer advice for fixing it, but until you have, if you hold down alt as you drag a file, it will copy it instead of move it. I use this instead of cmd-C and V anyway as find it quicker....
     

Share This Page