Cant patch Frozen throne.. Help

Discussion in 'Mac Basics and Help' started by beanisme, Aug 20, 2008.

  1. beanisme macrumors newbie

    Joined:
    Jun 14, 2008
    #1
    i recently just installed warcraft 3 frozen throne on my macbook. however, i cant seem to patch it to the latest version. connecting to bnet doesnt work for me.. so i tried manually patching. the patching was successful but after patching i cant run the game anymore. my version is 1.07(its written at the start page of Frozen Throne, bottom right corner).

    Anyone have any ideas to help?
     
  2. Fabiano macrumors regular

    Joined:
    Jan 30, 2008
    Location:
    Palmas, Brazil
    #2
    I think you may have the same problem I had before. It appears that there is a known issue with the last patch (1.22) related to Frozen Throne. What you should do to solve the problem:

    Uninstall FT and RoC, reinstall again. Then manually download and install the last patch before 1.22, that is, 1.21b. Last, download the update patch from 1.21b to 1.22, install it, and you're ready to go :)

    Let me know if worked.
     

Share This Page