can't ping pc or mac thru wireless router

Discussion in 'Mac Basics and Help' started by Brendanmac, Mar 11, 2008.

  1. Brendanmac macrumors newbie

    Joined:
    Mar 10, 2008
    #1
    I have an iMac (10.5.2) and a pc (xp home) successfully connecting to the internet through a WRT 300N Linksys router, but I cannot ping either pc to mac or mac to pc through the router

    So I cannot wirelessly transfer the files on my pc to the mac because neither pc nor mac see eachother.

    I can't find anyone who can solve this, can anyone help

    Thanks
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    How's your network set up? If it is set up the way I think it is, I know what the problem is, and what a good solution would be.

    If your network looks like this:
    Code:
    (Internet)
    |
    Modem
    |
    Router
    |    |
    Mac  PC
    
    I know precisely what the cause is, if this is the case. Your router does not permit file-sharing pass-through traffic on the LAN side (this is a common feature of most routers). The solution is to get a hub or switch, and insert it between the router and the computers connected to it, so the network now looks like this:
    Code:
    (Internet)
    |
    Modem
    |
    Router
    |
    Hub/Switch
    |    |
    Mac  PC
    
    This is how my network at home looks (except there are lots more devices connected to the switch), and file sharing between the various computers works perfectly, as well as internet access.
     
  3. Brendanmac thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    #3
    my configuration is as you assumed but your solution requires ethernet cable connection to the hub rather than wireless; there must be another solution. But thanks
     
  4. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #4
    The WRT300N has AP isolation set to enabled by default. Just change that to disabled instead in your router's web interface. You should find that in the Wireless tab, under Advanced Wireless Settings.

    You may want to make sure the change doesn't pose a threat to your network before doing it.
     
  5. Brendanmac thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    #5
    You're right AP isolation is set to enabled. Do you know how I check to see that there is no threat to the network?
    thanks
     
  6. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #6
    As long as you have properly secured the access point with WPA or similar you should be "safe". Just beware that if you let someone else connect to your network via wireless (e.g. for internet access) they will be able to see the other wireless devices. Also keep in mind that the AP isolation doesn't block the connection between wired and wireless devices at all.

    I would disable AP isolation without fear if you are the only one using the network.
     
  7. Brendanmac thread starter macrumors newbie

    Joined:
    Mar 10, 2008

Share This Page