Can't play favorite game :(

Discussion in 'MacBook' started by embalmess, Nov 1, 2008.

  1. embalmess macrumors member

    Joined:
    Aug 20, 2008
    #1
    Everyone, if you like multiplayer games online, the BEST is isketch.net ; however, I still can't play it on my new blackmac! (or previous others) Can you? I get "shockwave 10 is compatible, but not 11, etc...." Is there anything I can do? I have tried "opening in Rosetta" and that doesn't work either. *sigh*

    Now, I know certain things are just not available, like Netflix instant view movies, etc... (come on Netflix!!!)

    I play on my old Dell, but sheesh, I would love to play on my fresh new mac. :eek:

    p.s. Am I allowed to mention all these other sites on here? hehe
    :p
     
  2. PeterQC macrumors 6502a

    PeterQC

    Joined:
    Jun 30, 2008
    #2
    Did you tried Safari or FireFox? So Far I can't play with Firefox. Too bad, since it was a rather good games to waste time.
     
  3. ref26 macrumors 6502a

    ref26

    Joined:
    Mar 13, 2008
    #3
    I tried both Safari and Firefox, no luck with either. I used to play a lot when I was younger, totally forgot about isketch. Now you made me wanna play and I can't :( lol
     
  4. moongravy macrumors member

    moongravy

    Joined:
    Mar 21, 2006
    Location:
    Cardiff, Wales UK
    #4
    Works with Firefox 3 here using Rosetta after installing the (Power PC only) plugin.
    Tried with Firefox 2 (Rosetta) & IE (PPC anyway) and it could not connect to the game server.
     
  5. mrmayor92 macrumors 6502

    Joined:
    Jul 12, 2008
    Location:
    PA
    #5
    did you try using opera?


    (i dont even know if they make opera for the mac but its worth a try)
     

Share This Page