Can't print from Mac OS X to Linux print server

Discussion in 'Mac Basics and Help' started by rrpalma, Mar 29, 2009.

  1. rrpalma macrumors member

    Joined:
    Sep 21, 2008
    #1
    Hello,

    I'm new to Mac OS X, but have been working with Linux for almost 9 yrs now. I have set up a Linux box with CUPS 1.3.9. I can print from the server, and from other Linux stations to that remote server. However, I can't print from a client MacBook.

    I set up CUPS on the client Mac via http://localhost:631 and created a printer associated with the remote queue / printer on Linux (the URL I use on OS X is http://mylinuxserver:631/printers/hpprinter and the driver is RAW).

    I have no problems sending a test page from the CUPS web interface on Mac OS X to the Linux server -- the test page gets printed OK. However, I can't see the printer I just defined from other Mac OS X apps, and neither can I see it from the Add Printer Dialog on System Preferences (it's empty).

    I tried creating the printer at the Add Printer dialog, but it would neither let me specify an HTTP URL (as far as I know, I had to use the IP icon on the toolbar) nor specify "RAW". So I tried creating a "dummy" printer in the Add Printer dialog, with a basic config, and then changing it from the CUPS web GUI. This didn't work either, since when I went back to the Add Printer dialog, the printer was gone.

    Any ideas? I know this should be easier ... and no, I don't intend to run SAMBA.

    Thanks for reading!
     
  2. rrpalma thread starter macrumors member

    Joined:
    Sep 21, 2008
    #2
    problem solved

    Problem solved. It turns out that Mac OS X 10.5 doesn't listen by default to CUPS broadcasts that advertise network printers running on other CUPS servers. So, on a terminal session at the Mac, just type

    cupsctl BrowseProtocols='"cups dnssd"'

    and then all printers will show up on the Add Printers dialog. They can later (if one desires to) be modified via the local CUPS web gui.
     

Share This Page