can't print through Airport Express

Discussion in 'MacBook Pro' started by jules105, Sep 19, 2012.

  1. jules105 macrumors newbie

    Sep 19, 2012
    I have a Macbook Pro with OS 10.5.8. The internet/wi-fi works fine for going online. But I can't get the printer to print when it is plugged into the airport express. I called Epson support (I have an Epson Workforce 30) and they seemed to think it was a 'network problem'. The printer works fine when I plug it directly into my computer via USB. I tried the Apple web site troubleshooting guide and none of that worked.

    I found an old post in one of the archived forums of a solution, the first steps described here: In Printer Setup Utility under the "Printer List" window, select the Add icon to get the list and then select "IP Printing" from the top half of the window rather than the normal "Rendezvous". When you do this you get a drop-down window with several fields.

    From the top:
    First field is "Printer Type" - that should show a small split screen with Rendezvous at the top and 3-4 options below such as "LPD/LPR". Select Rendezvous.

    Second field is "Printer Address" and when you put the mouse on the up/down arrow button you should see the name of your printer in bold. Select it (you might also see something greyed out - for me this was "Socket/HP Jet Direct", but of course you can't select greyed out items).

    But I do not get the option of rendezvous and when I click the arrow for printer address the name of my printer did not come up. I have tried everything I can think of and still I cannot print through the Airport Express.:(
  2. jules105 thread starter macrumors newbie

    Sep 19, 2012
    not compatible

    I just contacted Epson again and they told me that this printer is not compatible with any wireless devices only supports a direct connection to the computer. What a big bummer! lame.
  3. stzheng macrumors newbie

    Jan 16, 2013
    I have a Canon icMF4010B, I asked canon they do not know if it's compatible with airport express.

Share This Page