Can’t publish to YouTube from camera roll in iOS 12?

sandman42

macrumors 6502a
Original poster
Oct 23, 2003
957
59
Seattle
After updating to iOS 12, I noticed that when you select a video in the camera roll the option to upload it to YouTube has been removed. Anyone know if this is intentional, a bug, or how to restore it?

I have given YouTube permission to access my camera roll and microphone, and I can upload videos from my camera roll within the YouTube app, but in prior versions of iOS it was possible to do that directly from the camera roll.
 

KnightofRepublic

macrumors newbie
Apr 10, 2018
5
1
Portland, OR
After updating to iOS 12, I noticed that when you select a video in the camera roll the option to upload it to YouTube has been removed. Anyone know if this is intentional, a bug, or how to restore it?

I have given YouTube permission to access my camera roll and microphone, and I can upload videos from my camera roll within the YouTube app, but in prior versions of iOS it was possible to do that directly from the camera roll.
[doublepost=1538360365][/doublepost]I have noticed that as well. Also within iMovie I try to upload to YouTube and it fails every time. Hope they fix this.
 

cynics

macrumors G4
Jan 8, 2012
11,554
1,873
I also do not have the option for YouTube in the photos app.

[doublepost=1538360365][/doublepost]I have noticed that as well. Also within iMovie I try to upload to YouTube and it fails every time. Hope they fix this.
Works fine in iMovie for me.

FEC21CFB-F1EC-49F6-8126-65D980AB6C16.jpeg
 

cynics

macrumors G4
Jan 8, 2012
11,554
1,873
I just tried it again. I even logged out of my account and logged back in. Tried a small video upload and it immediately failed. Strange. Thanks.
Did you try using a video encoded with H264 without slow mo or anything? Not that you should have to but for diagnosing compatibility.

The video I tried above was 10 seconds 1080p@60hz.
 

KnightofRepublic

macrumors newbie
Apr 10, 2018
5
1
Portland, OR
Did you try using a video encoded with H264 without slow mo or anything? Not that you should have to but for diagnosing compatibility.

The video I tried above was 10 seconds 1080p@60hz.
Yeah my video was just plain regular video recorded from my phone. No effects or anything. I can upload it through the YouTube app but not through the iMovie app.
 

KnightofRepublic

macrumors newbie
Apr 10, 2018
5
1
Portland, OR
So The YouTube app had an update today that seemed to fix my iMovie upload problem. Works great again.

Still wish Apple would add the option to upload to YouTube from the photos app. I miss that.

Thanks for the help!!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.