Can't put app on a device

Discussion in 'iOS Programming' started by erosenba, Aug 12, 2009.

  1. erosenba macrumors newbie

    Joined:
    Aug 12, 2009
    #1
    Hi,
    I know there are tons of people with this problem and just as many websites trying to figure it out but I still can't figure out what's going on. I'm extremely new to iphone development (so I apologize if I've missed something stupid) and have tried everything that I can understand on the sites with no avail including scrapping everything and starting over, trying new profiles etc.

    Currently I have the Apple Worldwide Developer certificate installed to my keychain as well as an "Iphone Developer:Erin Rosenbaum" certificate (this shows a private key underneath it). I have one device registered in the portal (its an ipod touch running 2.2.1). I currently have one provisioning profile (composed of app id: AMIKeyboard 'bunchOfRandomCharacters'.*, then my certificate and my device) which is installed and xcode and on the device. When pressing Build&Go I get the error: "Code Sign error: Provisioning Profile 'bunchOfNumbersAndLetters' can't be found". In the build info for the project I've set the Code Signing Identity to "Any iPhone OS Device" and "Iphone Developer: Erin Rosenbaum (randomCharacters)" (which was the only option aside from "Don't code sign" and "other").


    Any suggestions on how to fix this would be very appreciated. Thanks.
     
  2. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #2
    'bunchOfRandomCharacters' != 'bunchOfNumbersAndLetters' ?
     
  3. erosenba thread starter macrumors newbie

    Joined:
    Aug 12, 2009
    #3
    correct.... the Application Id is N2W5KY3RXT.* and the error is: "Code Sign error: Provisioning profile 'B67BEB92-C038-47FB-A995-C8FA150F5704' can't be found".
     
  4. erosenba thread starter macrumors newbie

    Joined:
    Aug 12, 2009
    #4
    UPDATE: I ended up copying everything into a new project, making a new app id and provisioning profile, put the com.companyname.appname into the bundle identifier and it all worked.
     
  5. coxaqui macrumors newbie

    Joined:
    Aug 4, 2009
    #5
    Yeah

    Same thing I did, did you figure out how to delete the old references in your developer web interface?
     

Share This Page