Can't put display to sleep when encoding

AlexisV

macrumors 68000
Original poster
Mar 12, 2007
1,603
95
Manchester, UK
Whenever I encode a DVD with iDVD, the display/screensaver settings are ignored and the screen stays on permanently. This is pretty annoying when you're trying to sleep in the same rooms as the Mac as it throws out a lot of light!

Is there anyway to get the display to go to sleep when it's running iDVD? I'm using the 2.4Ghz 20" alu iMac.
 

muusevic

macrumors newbie
Apr 23, 2007
12
0
Hi, I have the same problem, and it's indeed VERY annoying because I do my encoding over night and I'm sleeping right next to may computer...
 
Comment

richard.mac

macrumors 603
Feb 2, 2007
6,299
2
51.50024, -0.12662
its probably because youve only set your computer to go to sleep after a certain amount of time and not the display. if your ripping DVDs the CPU is not idle and the machine wont go to sleep until it is idle after the amount of time you have set.

in the energy saver preferences set your computer to go to sleep after however long you think it will take to rip the dvd and set the display to turn off after a certain amount of time. the display should turn off even if the computer is not idle.

if this still doesnt work you can set a screen corner to turn off the display. set this in the exposé and spaces preferences.

or you could always turn the screen brightness down.
 
Comment

Big-TDI-Guy

macrumors 68030
Jan 11, 2007
2,606
13
Just set up a "hot corner" for "sleep display" - that is what I do when I'm encoding, works just fine.
 
Comment

GSMiller

macrumors 68000
Dec 2, 2006
1,666
0
Kentucky
its probably because youve only set your computer to go to sleep after a certain amount of time and not the display. if your ripping DVDs the CPU is not idle and the machine wont go to sleep until it is idle after the amount of time you have set.

in the energy saver preferences set your computer to go to sleep after however long you think it will take to rip the dvd and set the display to turn off after a certain amount of time. the display should turn off even if the computer is not idle.

if this still doesnt work you can set a screen corner to turn off the display. set this in the exposé and spaces preferences.

or you could always turn the screen brightness down.
Just set up a "hot corner" for "sleep display" - that is what I do when I'm encoding, works just fine.
I do this too. My bottom left corner activates the screen saver and my bottom right corner puts the display to sleep, which comes in very handy when I'm encoding movies overnight or are away from the computer.
 
Comment

muusevic

macrumors newbie
Apr 23, 2007
12
0
I have done all of that, I'm using apple computers for a long time and I know these prefs, but while encoding video in iDVD, the computer ignores them...
 
Comment

jacklink01

macrumors member
Apr 2, 2008
30
44
Lafayette, IN
same here

i think that we all know how to put the display to sleep.

the problem is that it will not stay asleep for even 3 seconds after you put it to sleep (even with hot corners/screen corners)

I also have a 20" alu iMac, Does anyone think that the problem may only occur on the iMacs?

I make DVD's ALL the time. So not being able to put it to sleep while i'm trying to sleep is not very helpful.

any thoughts?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.