Can't Pwn 2G iPhone !!

Discussion in 'Jailbreaks and iOS Hacks' started by blimeyoriley, Sep 18, 2008.

  1. blimeyoriley macrumors member

    Joined:
    Jan 15, 2008
    #1
    Hi , i really need someone's help - got myself into such a mess !!

    Basically my friend has a 2G iphone which he bought from New York in Nov 2007. The firmware version was 1.1.1.

    I remember jailbreaking it with jailbreakme.com and unlocking it with AnySim 1.1

    Recently he asked me if I could upgrade it to the new 2.1 firmware. Ok, i was a bit rusty, hadn't hacked an iPhone for aages but i gave it a go.

    First i wanted to Re-Lock the AnySim lock , but i read somewhere that this was unecessary.

    So OK, i put his iPhone into DFU and restored + updated with iTunes to 2.1.

    Everything seemed to be going great, the restore was sucessful, and his fone returned to the Slide For Emergency screen.

    Then i created the custom 2.1 firmware with Pwnage software, and tried to restore using iTunes ( alt + restore )

    But everytime I do this i get the following error: "The iPhone "iPhone" could not be restored. An unknown error occurred (6)"

    Infact everytime I ( alt + restore ) to any other firmware version I get the same error (sometimes with a different number)

    I have tried different cables, all USB ports, tried on VMWare running XP, even tried on a Vista PC, but keep getting the same error !!

    Someone please help , my friend is moving away on Sunday , and needs his phone before then !!

    Thank You !!
     
  2. LSUtigers03 macrumors 68020

    LSUtigers03

    Joined:
    Apr 9, 2008
    #2
    Use quickpwn it doesn't use itunes to restore custom firmware.
     
  3. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #3
    Did you put the phone in DFU before restoring to the Custom .IPSW?
     
  4. blimeyoriley thread starter macrumors member

    Joined:
    Jan 15, 2008
    #4
    Thank you so much for your advice, but I actually solved it myself before reading the posts !!

    Here's what I did in case anyone is interested:

    1.Found a PC with iTunes 7.7

    2.Uninstalled

    3.Installed iTunes 7.5

    4.Renamed the iTunes 7.7 ituneslibrary file (as 7.5 said it couldn't read it, so wouldn't open !). 7.5 then created a new ituneslibrary file

    5.DFU'd iPhone and shift restored to 1.1.4

    6.Found a computer with iTunes 8 (my MBP in this case)

    7.alt restored the PWND 2.1 firmware !!

    Basically the problem is that iTunes has an issue with downgrading firmware. For example I found i couldn't "downgrade" my 2.1 iPhone on iTunes 8 ( to anything !! i tried 1.1.1, 1.1.2, 1.1.3, 1.1.4 ). Even the custom 2.1 firmware wouldn't work because iTunes saw this as a "downgrade"

    But when i connected the iPhone to iTunes 7.5 (which didn't support the 2.1 firmware) it let me "downgrade" to 1.1.4.

    I could then use iTunes 8 to go from 1.1.4 to the custom 2.1 !!

    Infact I actually initially downgraded to 1.1.1 in iTunes 7.5, then tried to go from 1.1.1 to custom 2.1 in iTunes 8, but this gave me a 1600 error !!

    So i'm not sure about 1.1.2, or 1.1.3, but you can definitely go from 1.1.4 to a custom 2.1 on iTunes 8 !!

    I hope my experiences save someone some valuable time !! Took me 15 hours of trial and error to finally complete the upgrade !!
     
  5. davidn3 macrumors newbie

    Joined:
    Sep 21, 2008
    #5
    Hey, I'm new here.

    I am having the same problem as you. I am on mac, and I deleted itunes and installed itunes 7.5. When I try to downgrade from 2.1 to 1.1.4 I get an error message.(1604) Do I have to be on windows for it to work? If any one has any suggestions please let me know.

    Thanks.

    David
     

Share This Page