Can't quit Safari, quit option grayed out

Discussion in 'Mac Apps and Mac App Store' started by davidinva, Mar 13, 2012.

  1. davidinva macrumors 6502a

    Joined:
    Mar 29, 2009
    Location:
    Shenandoah Valley of Virginia, USA
    #1
    Finish browsing and tried to quit Safari from the keyboard. Nothing. Checked the Safari menu and the "quit" option is grayed out and not available. So decided to restart and got the message "can't quit because Safari is still open." Going to shut down and restart, but curious what caused this. Thanks.

    ----------

    After shutting down with the power button and restarting, Safari looks normal. Still curious. Thanks.
     
  2. LaWally macrumors 6502a

    Joined:
    Feb 24, 2012
    #2
    You could have just gone into Activity Monitor and killed the Safari process. No need to restart your computer.

    I suspect a bug in Safari? Which version of Safari? Lion?
     
  3. davidinva thread starter macrumors 6502a

    Joined:
    Mar 29, 2009
    Location:
    Shenandoah Valley of Virginia, USA
    #3
    Thanks. I'll remember Activity Monitor, not used to using that. Using Safari 5.1.2 on Snow Leopard (10.6.8). Safari ok now, and I've never seen this bug before.
     
  4. MattLafferty macrumors member

    MattLafferty

    Joined:
    Apr 18, 2010
    Location:
    New Jersey
    #4
    I've had that happen recently as well. I'm running Lion on a Mac Mini. Odd.
     
  5. rventura macrumors newbie

    Joined:
    Apr 3, 2012
    #5
    Same Issue

    I have had the same issue happen. Go to shut down, stopped by Safari. Try to quit Safari using Command+Q and nothing happens. Quit is grayed out and I had to Force Quit Safari through Activity monitor.

    This has happened now on two separate occasions. I don't think I did any recent updates. I have Safari Version 5.1.3 (7534.53.10) .

    After force quitting, and re-opening, I can Quit Safari normally. Weird bug. :D
     
  6. Torrijos macrumors 6502

    Joined:
    Jan 10, 2006
    #6
    Use the Force quit menu (alt-cmd-esc)

    Weird bug I got a few times too. No idea why.
     
  7. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #7
    Option-Right Click on the icon in the dock; from there the context menu will have a choice for "Force Quit". Use that, I've never see that not work.
     
  8. MSM Hobbes macrumors 6502

    Joined:
    Aug 25, 2006
    Location:
    NE Hoosierana
    #8
    MBP, running OS = 10.7.3 and Safari = 5.1.3 ((7534.53.10),,, same as prior poster;
    Wanting to quit Safari, so can reboot MBP, but can't do;
    Tried: control-right-click on dock icon = Options, Show Recent, Open
    Tried: Safari drop down = greyed-out Quit Safari
    Tried: command-Q = nothing…
    Next… going to the Activity Monitor.

    And an interesting nugget also is that the "x" on the Safari tabs are missing :confused: can only close tabs via command-w
     
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    Read post #6.
     
  10. MSM Hobbes macrumors 6502

    Joined:
    Aug 25, 2006
    Location:
    NE Hoosierana
    #10
    Yes, thanks, I did read that, and its a path I was already aware of… in frustrations however I did not included in my list of what I was going to do next (for example if not the Activity Monitor route), and that alt-cmd-esc is what I ended up doing.

    As to potentials of why this happened, I wonder if its due to low system resources or the such? I had 6 different windows open, with ~12 tabs in each, plus iPhoto running while processing some RAW images. And it had been few weeks (~9?) since a reboot, with a lot of web-based searching & three different email accounts therein too.

    Safari is now 5.1.7, and OS is 10.7.5.
     
  11. neptunerx macrumors newbie

    neptunerx

    Joined:
    Dec 5, 2014
    #11
    Problem still exist. OS X 10.11.3 Late 2015 MBPr 13. 8GB of RAM. Safari Version 9.0.3 (11601.4.4)
     

Share This Page