Can't re-install any Mac OS X on iMac 6,1 late 2006

Discussion in 'iMac' started by be236, Jun 26, 2017.

  1. be236, Jun 26, 2017
    Last edited: Jun 26, 2017

    be236 macrumors newbie

    Joined:
    Jun 7, 2017
    Location:
    Seattle
    #1
    So, I have this iMac with 4GB RAM and 2TB hard drive. It had a working Lion (OS X 10.7.5) installed and running fine. Then I did this Yosemite Unsupported install and got it up to 10.10.5, but since the GeForce 7300GT was not working correctly with it I wanted to downgrade back to Lion.

    However, when I insert in Lion DVD and reboot with it, it would boot up until it got to a blank white screen and stuck there forever.

    Even tried a Leopard disk and Snow Leopard disk, all failed at some point during the boot up, either locking up at Apple screen or into the white screen, never getting to the menu to install Mac OS X.

    I even tried to boot using iMac original DVD with Tiger on it and it gave me the Mac -version of BSOD.

    However, I did a SuperDuper copy of OS X 10.10.5 to external SATA HD and was able to boot up using this external HD. Then I tried to SuperDuper it back to my internal HD, but then it would boot and get stuck into the white screen!

    Arg...

    Then I used this Mac6,1 in Target Disk Mode and with another Mac 5,1 (with 10.10.5 installed) I booted up the OS X 10.7 Lion DVD and "installed" into my Mac6,1 HD and after it was done, I can boot up my Mac5,1 and it ran 10.7 from the Mac6,1 HD.

    However, when I disconnected Firewire cable and booted Mac6,1 it ran and got to white screen. In Single User Mode, I noticed it got stuck at "waiting for DSMOS," indicating it thinks my HD is not on an original Mac.. not sure how I can get past this...

    Also, tried to swap up the RAM on the Mac 6,1 but didnt seem to have any effect...

    Thoughts? What could be wrong? The main issue is that NO Install DVD will boot up correctly directly on my Mac 6,1...

    Help...
     
  2. nambuccaheadsau macrumors 65816

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #2
    You may be in the same position as folks who did a hack on Mac Pro 1.1 and 2.1 models to run an OS later than Lion. The EFI and kext have been altered. Have seen many posts about going back, but it seems to be a very difficult thing to do reverse the changes.
     
  3. be236 thread starter macrumors newbie

    Joined:
    Jun 7, 2017
    Location:
    Seattle
    #3
    I thought EFI was in firmware? Can't I reset it back? and I thought kext are just files on the HD? I've re-partitioned and reformatted the HD a few times, no errors in Disk Utility.

    What's troubling is that I cant even hold down C to reboot the iMac original DVD with Tiger on it.. if I choose it from Option menu, then it boots up and then gives me the BSOD screen.

    Somehow I think the GeForce 7300GT is has been altered somehow... though I can boot from external HD with my saved OS X 10.10.5 and get to the desktop just fine.

    And also with a hacked 10.10.5 on an iMac 5,1, I was able to boot up my Lion DVD just fine and go to the install menu just fine...

    Just this iMac 6,1 has the problem, can't re-install any OS X from Tiger on up. Do you know the posts that show this problem?
     
  4. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #4
    I'm not aware of any changes that happen at the firmware level, instead the it happens at the software level to change how the software communicates with the firmware (hence the replaced boot.efi file). iMac 6,1 owner myself here, have installed Mountain Lion (unsupported boot.efi replacement via MLPostFactor), even Linux Mint, and never had an issue like the OP's.

    @be236, I assume you've tried the standard troubleshooting (NVRAM reset, SMC reset)? Will the iMac 6,1 boot from the DVD in the iMac 5,1's DVD drive if you place the 5,1 in Target Disk Mode, or does that fail as well?
     
  5. be236, Jun 26, 2017
    Last edited: Jun 27, 2017

    be236 thread starter macrumors newbie

    Joined:
    Jun 7, 2017
    Location:
    Seattle
    #5
    Yes, I've done NRAM reset (option+command+P+R) and SMC reset (unplug Mac and press power button for 5+ seconds)... no change...

    Oh, I've not tried to use iMac 5.1's DVD in Target Disk mode for iMac 6.1... will try that next when I get a chance. Also, I have external DVD burner as well, I could try to see if I can boot off that external DVD drive with my Mac 6.1... ?

    I can't imagine my iMac 6.1 DVD drive is bad, since once I could boot it into 10.10.5 using external HD, I can insert in any DVD and it reads those DVDs just fine...

    update: I tried that Target Disk mode attempt and same problem, after rebooting to the Lion DVD, I see the Apple spinning wheel, then after 5-10 minutes it just went to the white/blank screen and stuck there forever.. though the caps-lock key lights on and off as I press it... so not completely stuck I think, but just spinning in the background, which I cant see.
     
  6. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    From the original post:
    "However, I did a SuperDuper copy of OS X 10.10.5 to external SATA HD and was able to boot up using this external HD."

    There's your solution.
    Go with what works.

    With an 11-year-old iMac, perhaps it's time to start looking for a replacement...
     
  7. be236 thread starter macrumors newbie

    Joined:
    Jun 7, 2017
    Location:
    Seattle
    #7
    ... uh... as-is, this version of Mac OS X 10.10.5 does NOT support the GeForce 7300 GT, which makes this Mac almost unusable.. the graphics/screen redraw is awfully slow! Feels like I'm on a G3 PowerPC chip.
     

Share This Page