Can't re-install from recovery or CD

Discussion in 'MacBook Pro' started by zip22, Dec 11, 2012.

  1. zip22 macrumors newbie

    zip22

    Joined:
    Dec 10, 2012
    Location:
    NS, Canada
    #1
    :confused: Greetings all,
    I have a Mac Book Pro that came with Snow Leopard and not long ago I purchased Mountain Lion and installed from the app store. It totally slowed down the performance so a few days ago I attempted a HD erase and re-install from CD. Always what we learn after the fact! I tried to erase from the core storage utility instead of the utility on the disk.
    Then I made matters worse by trying to fix it. I did a partition that somehow ended being 159.3 of my 160 memory, so now there is no space on the recovery disk or the system disk to install and I can't re-size the partition.
    I now have the Hitachi drive with and orange disk under it titled Mac OS X Install CD. Under the super drive line, in attempting to create a new disk image to copy to, I also have disk1 (orange) called Mac OS X ESD Journalled and disk2 (orange) Mac OS X Base System. Both names that were in the drop down menu. Now I can't get anything to work in disk utility except verify disk. Always not able to unmount disk. Check app for open files.
    I did a start up from C and CD but utilities is low lighted so I can't access.

    I was then advised to open terminal and type unmountDisk 1 and 2 but getting back that some files could not unmount. Many of the "verbs" when I type diskutil list are responding as not recognized. I have ADHD so I can't remember exactly where I saw in terminal that I have 13 disks running? All of which I got unmounted but the ones listed above.

    I've done enough damage in disk utilitiy and don't want to mess more in terminal commands. I have been advised to zap pram? and try fs k? something
    but as you can see...I am clueless! I have no experience with disk utilities obviously and I may have to replace the HD I guess.

    With no room, I can't install disk manager and when I seek out files, the ones I would need like Mountain Lion are dimmed out.

    Anyone have the clue that I don't?
    Thanks in advance if you do.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Whoa :eek:... I'm not quite sure how you got your partitions in this state.

    Try booting from the Snow Leopard DVD and start Disk Util. Then click on the drive name itself (like Seagate 500GB or whatever) and not any of the partitions. Now erase the entire disk and format to Mac OS Extended as one partition. Then try to reinstall Snow Leopard.
     
  3. zip22 thread starter macrumors newbie

    zip22

    Joined:
    Dec 10, 2012
    Location:
    NS, Canada
    #3
    Thanks, but

    I tried that already and no go. It is now saying is the original start up disk but I can not erase or re install. I have no room on HD to download anything and the partition will not let me re size. Any attempts to restore say unable to unmount. I typed every command I know to unmount all disks but they don't work. When I attempt to unmount the original which now is a partition it says "/" busy.
    Info on all say they are type: partition. When I checked under open disk image, the one named Mac OS X Base System disk file is named alias and is 1 byte.
    I am wondering if startup in verbose/single user might help.
    It seems that the recovery start up disk is gone. I am not sure if this is due to Mountain Lion or if it erased from Mac OS X 10.6
    There are no Apple Stores around here as far as I know. I purchased from Future Shop and "techs" are hit and miss in each location. Computer Geeks may be the best place to go but I would prefer to try everything I can myself first (to learn) and visit a tech as last resort.
    They say...everything is easy once you know how!
    The list I get in terminal that are not working....unable to unmount....I don't know if the terminal is Mountain Lion or Mac OS X 10.6 Maybe I am typing the wrong commands fr the disk mounted?
    It seems that because they are all partitions, they will not unmount because they arte all parts of the same disk and files are mounted on all of them.
    Any idea on how t unmount all mounted disks from terminal? Anything like Windows BIOS? :eek:
     

Share This Page