Can't Re-install Mac OS X Snow Leopard :(

Discussion in 'macOS' started by Songbirds, May 22, 2011.

  1. Songbirds macrumors newbie

    Joined:
    May 22, 2011
    #1
    A couple of months I completely removed mac of my computer to reinstall it for a reason which I can't remember, only to find that my disc had been snapped in half so I couldn't re install it.

    I received my Mac OS X Snow Leopard V10.6 Retail Family Pack in the post this morning (My iMac originally came with V10.6), unpacked, inserted it into my computer, tried to boot. The apple logo came up with the little loading sign, after about 5 minutes of waiting the screen goes grey and a notification comes up saying something like "You need to restart your computer". Done that, tried to re-boot the disc and it done it again. Tried five times and it still done it! My computer recognizes the disk, and it recognizes it in windows.

    I just used the disk to re-install bootcamp in windows to see how it goes, and it installed fine so I don't think there's a fault in the disk.

    Does anyone know what's wrong or what I can do?

    Thanks you.
     
  2. Hansr macrumors 6502a

    Joined:
    Apr 1, 2007
    #2
    The computer most likely came with a later version of OSX than is on the new disk. E.g. 10.6.4 when the disk only contains 10.6.0 or something similar.

    You'll need to get a later version or a copy of the restore disk from Apple
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    Get a restore disk from Apple to be sure you have the right version of osx for your computer.
     
  4. applemagic123 macrumors regular

    applemagic123

    Joined:
    Aug 19, 2009
    #4
    The reason the retail SL disk won't work with your mac is because your mac probably shipped with a slightly higher version. You will need the install disk that came with your computer. Call 1800 MY APPLE and you can buy another one. This is why it's important to keep EVERYTHING that your computer came with.
     

Share This Page