Can't read WD SmartDrive

Discussion in 'MacBook' started by spiderhunter, Jul 5, 2010.

  1. spiderhunter macrumors newbie

    Joined:
    Jul 5, 2010
    #1
    Okay, so I have a Passport Essential External HD, and I'm beginning to have some trouble with it. When I plug it in via usb, i get the following message:

    "Disk Insertion: The disk you inserted was not readable by this computer."

    And it gives me two options, Ignore or Eject. Eject just brings up the warning again. Ignore ignores it.

    I've been searching the internet all day for solutions. Nothing I've done so far has worked.

    I tried resetting the usb drive by holding "command+option+r+o" (or whatever it is, I can't quite remember now)
    I've tried updating the WD firmware and software
    I've tried erasing the hard drive via both Disk Utility and the WD Smartware software.

    With Disk Utility, and the WD Smartware, it reads it as a 2 TB hard drive, but it's only 180 GB. I thought that was weird.

    I don't know. I'm stuck. At this point I'll sacrifice all the memory on it just to get it working again, but I can't figure this out. I would greatly appreciate some help. Thank you!
     
  2. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #2
    If the computer thinks it's 2 TB but is actually a much smaller drive, then your drive has a mechanical or electrical failure. You'll need to replace that drive.

    Is your drive still under warranty? You can check online.
     

Share This Page