Can't receive texts from iPhones since switching to Android..

Discussion in 'Alternatives to iOS and iOS Devices' started by BadboyHouse, May 10, 2015.

  1. BadboyHouse macrumors 6502

    Nov 1, 2011
    I switched over to an Android phone at the beginning of this week.

    Before I did the switch I made sure that I turned iMessage off on my iPhone 5S as well as making sure that my mobile number was not set up as a send/receive number on my iPad and MBP. I also went through the iMessage number de-activate process on the Apple website (received the code via text etc).

    Having done all that I still can't receive SMS texts from anyone with an iPhone or iPad - which is most of the people I know.

    I set up Google Hangouts for my other half so that she could still send me messages like iMessage.

    She even turned iMessage off completely, sent me a regular SMS, but after she turned iMessage back on it still thinks I'm on iMessage so it says the message is delivered but I obviously don't receive anything.

    I imagine this could be a bit of a problem since like I said above most of the people that message me, do so either from an iPad or iPhone.

    Has anyone been successful in de-registering a mobile number from iMessage and it actually working?

    Seems as if my mobile number is still linked somewhere but I've double checked everything I can think of.

    Any ideas?
  2. mrex, May 10, 2015
    Last edited: May 10, 2015

    mrex macrumors 68020


    Jul 16, 2014
    check that it is not sending imessages using ypur email address instead of a phone number. did you try to delete the old already existing imessage conversation and started new one? if the other person send a message through the old conversation, it might not work so you should ask everyone to delete the old conversations with you.

    and if you have done deactivating and deregistering correctly, call apple.
  3. MRU Suspended


    Aug 23, 2005
  4. Ke1ington macrumors 6502a


    Dec 29, 2009
    I've returned two phones (one android, one windows phone) because of Apple's inability to straighten this mess out. I likely would have made it back to iPhone eventually so not a huge deal but it's annoying when I want to tinker for a while.
  5. Robisan macrumors 6502

    Jan 19, 2014
    The problem may lay in the message settings of the sender phones. They need to switch your message contact settings to sms - otherwise they're sending to an iMessages black hole. I've also read of cases where senders have to delete all prior to/from messages and start a new sms message thread. YMMV.

    (Insert anti-iMessages, anti-Apple business model/practices rant here. IMO this is deliberate design by Apple.)
  6. gotluck macrumors 603


    Dec 8, 2011
    East Central Florida
    Working as intended :p

    That tool mru posted is supposed to work though seriously
  7. jamezr, May 10, 2015
    Last edited: May 10, 2015

    jamezr macrumors G4


    Aug 7, 2011
    I switch phones a lot. Every time i switch from an iPhone i have to tell all my iPhone friends to switch their settings for me to SMS. I think it is deliberate as well and part of the closed/controlling environment Apple encourages.
  8. BigRed1 macrumors 6502

    Dec 13, 2011
    Do you have an iPad or Mac using messages? You may have to disassociate those devices from your number as well.
  9. rugmankc Contributor


    Sep 24, 2014
    Until you work it out and if you "have" to have text between you and someone important right now try Signal for iOS and Text Secure for Android. It is also encrypted. Me and my son, the one who hasn't seen the Apple" light use it with no issues. :)

Share This Page