Can't register computer (MacBook Pro) to MobileMe.

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by PeterSmith, Jul 13, 2008.

  1. PeterSmith macrumors member

    Nov 12, 2006
    Cambridge, UK
    When I go to MobileMe preferences --> Sync -- > Advanced, no computer is listed as being synchronized. I hit "Register this computer" and get a spinning wheel for ever against "Registering computer". ("Reset sync data" is greyed out.)

    So I can't register, and hence can't sync.

    I'd be very grateful for any suggestions!!!!!

    [I'm on a MacBook Pro running 10.5.4, so everything should be up to date.]
  2. jackc macrumors 65816


    Oct 19, 2003
  3. MoonDogg macrumors newbie


    Jul 13, 2008
    Don't know if this will help for you.. but on My PC I was having the same issue. I opened iTunes and registered the computer for iTunes and then was able to sync with MobileMe. Its worth a try.
  4. boardtrick macrumors newbie

    Aug 2, 2007
    i've had a similar problem with my macbook pro and my imac...i hope the following suggestion helps:

    i resolved this problem by going to the accounts preference pane and removing the mobileme name associated with the account...after i did this i was able to register and sync with both computers

    hope this helps!
  5. PeterSmith thread starter macrumors member

    Nov 12, 2006
    Cambridge, UK
    Going nuclear ...

    I did solve my problem in fact, along with a raft of other annoyances, but by going nuclear (something I'd for quite other reasons been meaning to do for some time). :)
  6. Nick9597 macrumors member

    Mar 5, 2007
    This worked for me too. Thanks dude.
  7. 1ktamas macrumors newbie

    Aug 19, 2008
    what do you guys mean by accounts preference pane and removing the mobileme name?

    MobileMe support is a joke.

    Thank you,
  8. 1ktamas macrumors newbie

    Aug 19, 2008

    MobileMe sync worked fine on my home network, but won't work at my office. Both are connected wirelessly. Any ideas would be appreciated. At the office it doesn't even see my computer and I can't register or unregister it.

    Thank you,
  9. forestcat Guest

    Worked Like a Charm!

    I couldn't get my new MacBook to sync with MobileMe either. I followed the suggestion to delete the MobileMe User Name in the accounts preference pane. This worked like a charm! Thanks!!
  10. rvdparis macrumors newbie

    Jun 5, 2007
    paris, france
    Fix the registering error

    Try this.

    I tried everything, and I mean it. Repairing permissions, repairing keychains, registering my computer AND mobile me with the SAME ACCOUNT name/pass, deleting, editing, everything, but NOTHING WORKED. My computer would not show up and I could not register.

    But I found this and it worked for me, instantly:

    "I was trying out Apple's new MobileMe service and I was having a hard time registering my computer for sync. I would click the Register button and things would spin for a while and then nothing. No error message of any sort, it would just stop and the registration would fail. After searching log and hard on the web, I found an article that offered a number of potential solutions. It turned out my problem was a series of entries in my /etc/hosts file for I edited the file and removed the entries and voila, registration worked.

    Do the following:

    1. Type 'sudo nano /etc/hosts' in the terminal. Type your admin password.

    2. Delete any line that is related to dotmac. By default /etc/hosts contains only four entries.
    You can easily delete them from the command line by using the arrow
    keys to get to the right line, then press CTRL+K to cut them out.

    Save the file (CTRL+O then ENTER) and close the terminal window.

    3. Either wait for the OS X DNS server to reload the file, or restart your computer. I did the latter, just to be sure."


    whoever that guy is, he's brilliant.

    I posted it on
  11. thesharpster macrumors newbie


    Dec 9, 2008

    Just want to say thankyou very much to boardtrick. It worked... No thanks to those so called "genius" twats at the apple store in regent st. 2 hours with one of them and no joy, or 30 mins reading this forum....!! They are no better than Mcdonalds staff.
  12. d3h872 macrumors newbie

    Sep 25, 2001
    Tri-Cities, Washington
    Saved me today -- thanks.
  13. dcwinton macrumors newbie

    Jan 26, 2009
    Not sure I get this...

    I'm not sure I'm understanding this fix.

    The "mobileme name associated with the account" and the account are the same thing. There is no other "name" associated with my mobileme account except for my username/account name.
  14. dcwinton macrumors newbie

    Jan 26, 2009
    Okay...An update and another idea

    I couldn't register my iMac after a HDD crash and reconstruction, even though the instructions in MobileMe were correct. And the above instructions made no sense.

    So I tried "signing out" and signing back in on the account tab of System Preferences/MobileMe. That worked.
  15. BillB1953 macrumors newbie

    Feb 14, 2009
    Another registran wannabe

    Just bought a new MacBook and am trying to sync it with my desktop Mac using MobileMe. I go to System Preference, click on MobileMe and then Sync. Then to Advanced. I see there no registered computer and no option to register. Can anyone help? I am NEW to Mac and not all that computer-proficient. Can anyone help me fix this without degenerating into computer-speak?

    Am I right in assuming the first step is to get my new computer registered in MobileMe? My desktop, on the same screen shows My name and "'s iMac (this Computer)" On my new MacBook there is nothing and no way for me to enter anything. If I should get into this on my new computer I'm not even sure what the name of this new computer is!!!!

  16. macbookairman macrumors 6502a

    Jan 15, 2008
    United States
    First on the new MacBook go to System Preferences>MobileMe. Then Sign Out.
    Sign back in with your MobileMe account info, and see if enabling syncing will work now.
  17. schizoidwoman macrumors regular

    Jan 12, 2009
    On top of a steep hill in West Yorkshire.
    Out of the blue on Tuesday, my iMac and MB BOTH decided to stop syncing with MobileMe out of nowhere with a helpful error message telling me it had failed "due to an error" (very useful).

    I tried everything Apple suggested in their help pages and things MR readers suggested too but nothing did the trick. Neither computer was shown as registered and when I went in to register them, they just ticked over for ages but neither showed up. Eventually I had to contact MM support who told me to enter gibberish as the password in the MM preferences so I was told I couldn't log on. I did this and they told me to turn the router off and on again which struck me as tech support's last resort but I slavishly followed the suggestion with a heavy heart.

    The funny thing was, it worked for both the iMac and MB! Not sure why or if it was just a fluke but it's the first and hopefully last MM issue I've had because the "off and on again" fix always seems a bit dubious even if it does work!

    Next time, I'll try some of the solutions here too, it's always useful to have a resource!
  18. Beks macrumors newbie

    Feb 14, 2009
    Can't register computer (MacBook Pro) to MobileMe.

    I had the exact same thing on my brand new macbook pro. What did the trick was to sign out of mobile me in the mobile me settings under the Account tab. What happened was that I was somehow signed in under my name but without the part. When I signed back in (with this part added to my user name) I was able to sync everything and even see my other devices again.

    That simple, perhaps this will work for you too :)

Share This Page