Can't Reinstall Yosemite

Discussion in 'MacBook Pro' started by jclardy, Mar 22, 2015.

  1. jclardy macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #1
    I am selling my old rMBP (2012), I wiped the drive and it rebooted to the recovery partition. So far so good. After setting up the partition using disk utility and going to reinstall the OS it fails to download Yosemite from the mac app store. It says something along the lines of "operation couldn't be completed, try again later." This is over the past two days.

    I also am trying to download Yosemite on my new retina MBP (2015.) It tells me "OS X Yosemite is already installed." If I try to download it on my work iMac I get a different error and can't download it (Same iTunes account.)

    Has anyone ran into this issue? Is there any way to get the machine to install an OS properly without getting a USB installer? Is my iTunes account bugged?
     
  2. Wreckus macrumors 6502a

    Wreckus

    Joined:
    Jan 22, 2015
    Location:
    Edmonton, Alberta, Canada
    #2
    If your selling it, just do the internet recovery with whatever version came with the MBP. Let the buyer know of the version OS X installed and instruct them to install Yosemite via the App Store. Yosemite is free so its not like the buyer will be paying for it anyways.

    Less hassles.
     
  3. jclardy thread starter macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #3
    Well that is the issue, there is no OS on the laptop. It boots straight to the recovery partition where it won't let me download an OS. I tried with two different iTunes accounts (It requires one to download for whatever reason.)

    But I was able to get Yosemite downloaded from yet another computer to create a USB installer. Just annoying that I've had a useless laptop for 3 days because of mac app store issues.
     
  4. newellj macrumors 601

    Joined:
    Oct 15, 2014
    Location:
    Boston, MA, US
    #4
    Did you erase the OS disk, and are you reinstalling with the three key internet recovery method?
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    It sounds like you booted to the recovery partition on the drive rather than Internet recovery. Hold command-option-r (all three at once) to get to Internet recovery. Then erase the drive and install. That will get you the OS version that came from the factory and no AppleID will be required to do the DL.
     
  6. jclardy thread starter macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #6
    Sounds like this was the solution, but I got the USB install working.

    Still doesn't explain why Apple doesn't allow you to download Mavericks/Yosemite on a 2015 rMBP. Couldn't they just pop up a warning saying that it isn't compatible with your machine?
     

Share This Page