Can't remove Adobe Reader plugin from Safari

Discussion in 'Mac Basics and Help' started by Atius, Apr 18, 2014.

  1. Atius macrumors newbie

    Joined:
    Apr 13, 2012
    Location:
    Iceland
    #1
    I have a weird problem

    I am unable to disable the adobe readers plugin from safari.

    I have tried this so far:
    Delete AdobePDFViewerNAPAPI.plugin & AdobePDFViewer.plugin from /Library/Internet Plug-ins
    Cannot find any other files in the system by that name.

    Deleted the safari plist

    Tried making a new user.

    After uninstalling adobe reader with app cleaner all I get now is a message
    when trying to open a PDF in Safari:

    Before proceeding you must first launch Adobe Acrobat and accept the End User License Agreement.

    I just want the native pdf reader from Safari back but I am unable to do it.
    The adobe forum has been unable to help me so I turn to you :D
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    There are two places that plugin could be. The main system /Library/Internet Plug-ins where you looked, then there is also a user ~/Library/Internet Plug-ins folder under each user account.

    Click in the Desktop then hit shift-command-g and paste in this path then enter to get to the user plugin folder and see it plugin is in there also.

    Code:
    ~/Library/Internet Plug-ins
    Also, try just downloading a PDF to your Desktop then select it and hit command-i for the get info window. Now where it says Open With change that to Preview then click change all. Hopefully that will force PDFs to open in Preview.

    I know this Terminal command used to force PDFs to open using the built in Safari reader, but I'm not sure if it works any longer. Try quitting Safari then running this command in Terminal, then reboot and try Safari with a PDF.

    Code:
    defaults write com.apple.Safari WebKitOmitPDFSupport -bool false
     

Share This Page