Can't remove Blackberry from 'Browse Device' listing

Discussion in 'macOS' started by danlovaa, Nov 13, 2010.

  1. danlovaa macrumors newbie

    Nov 13, 2010
    I've been having a ton of problems trying to figure out how to remove my Blackberry from the listing of 'Browse Device' in the drop down bars of the bluetooth menu.

    I've removed from my favorites, I've reset bluetooth and everything, and it continually stays there. It's more of annoyance thing, and I cannot seem to get rid of it as hard as I try.

    I don't even have the Blackberry anymore and it's cluttering up the space in the 'Browse Device' category. I've researched this for the past 2 hours, and I can't seem to fix it. I appreciate any help in advance, I'm sure some will be reluctant to help because I'm new, but please, if you can help, I would really appreciate it.
  2. Hal Itosis macrumors 6502a

    Hal Itosis

    Feb 20, 2010
    Have you launched iSync and removed it from the device list?

    Might there be a bundle for it hanging out in the /Users/*you*/Library/Phones/ folder?
  3. danlovaa thread starter macrumors newbie

    Nov 13, 2010
    Neither of those! I never sync'd it up via iSync, so "Remove Device" is grayed out in iSync. And in the phone folder, there's nothing. From what I've researched about this, it seems to be a bug, but to be honest I don't really know.

    It's just irritating having that in the list even though I haven't had a blackberry in months.
  4. Hal Itosis, Nov 14, 2010
    Last edited: Nov 15, 2010

    Hal Itosis macrumors 6502a

    Hal Itosis

    Feb 20, 2010
    Probably lingering in a pref file somewhere. E.g., /Library/Preferences/ perhaps, or one of your user prefs.

    See if this terminal command spits out any answers:

    grep -ilr "Blackberry" {~,}/Library/Preferences 2>/dev/null

    [replace "Blackberry" with the exact string appearing in the device list (if necessary).]

    Edit: or this one maybe...

    defaults -currentHost find "Blackberry" |grep Found

    [try that one both with and without the -currentHost option.]

Share This Page