Can't remove items from dock

Sam/B

macrumors member
Original poster
Dec 31, 2005
88
0
Newport - South Wales
For some reason since installing a new OS I can't remove programs from my Dock anymore? I used to be able to just right click on the program and select remove from dock but everything program I now right click on says "show in finder" with no other options to delete it. I've only just recently installed OS X 10.3.9 (I can't remember what I used to have on here as this was a new OS CD).
 

ThunderLounge

macrumors 6502
Sep 20, 2006
332
0
As mini mentioned, just drag it off the dock.

The "oldest" version I have running on any of my boxes is Jaguar, so I verified and it doesn't have the "remove from dock" option either. Off the top of my head I don't know when it was removed but just dragging it off works like a charm, as does dragging something to add it.
 

ncurtis

macrumors newbie
Jun 29, 2008
7
0
im having the same problem running leopard except mine happened out of no where. Just wont let me drag and drop off the dock and there is no remove from dock option either.
 

billmister

macrumors 6502
Sep 15, 2007
338
0
im having the same problem running leopard except mine happened out of no where. Just wont let me drag and drop off the dock and there is no remove from dock option either.
Also it will not let you drag it off the Dock if the application is open. Example, if iTunes is open and running and you close the screen, the app will not be removed from the dock untill you click and hold and select Quit. Once it quits then you will be able to move it from dock to anywher on the screen and it will Poof (vanish)
 

ncurtis

macrumors newbie
Jun 29, 2008
7
0
not sure what was causing the problem but i was able to fix it be deleting the preference files for the doc.
 

thecoolk

macrumors newbie
Jul 22, 2008
8
0
i have the exact same problem and i just can't drag it off the doc or remove it in anyway. i used to be able to do it!! :mad: my version is 10.5.4 and i really would like to know how to remove icons from doc! help!
 

ncurtis

macrumors newbie
Jun 29, 2008
7
0
To fix the problem your having your going to need to delete the following files

com.apple.dock.db
com.apple.dock.plist

They are located in

/Macintosh HD/Users/HOMEFOLDER/Library/Preferences/

once these files are deleted open terminal and type

killall Dock

Now move your mouse to the bottom of the screen and the Dock will relaunch back to its factory settings.
 

thecoolk

macrumors newbie
Jul 22, 2008
8
0
still not puffing out!

Thanks "ncurtis"! I did what you told me to do and the doc did go back to its original factory settings.
BUT, i can NOT get rid of the items on doc!!
help!!:eek:
 

thecoolk

macrumors newbie
Jul 22, 2008
8
0
Solved!

this may not be the case for most of you but i found out that...
under system preferences>parental control>"(your account)">system, there is a list of things that if you tick them off, you are able to do. it's at the bottom of the page and all you have to do is
-make a tick next to "Can modify the Dock" by clicking the small white box next to it.
-restart your computer.

voila! :D

try it if you have "parental control" on your account.
 

ncurtis

macrumors newbie
Jun 29, 2008
7
0
Try repairing disk permissions, it could be a permissions file on your pref folder or on the actual plist files. You can run this by going to Applications/Utilities/Disk Utitlity
 

ajleonard

macrumors newbie
Jul 29, 2008
5
0
i had the same problem and got it fixed thanks to all of your help. so thanks!

does anyone know how this happened to us in the first place? is it just some random act?
 

wad11656

macrumors member
Feb 20, 2009
47
0
this may not be the case for most of you but i found out that...
under system preferences>parental control>"(your account)">system, there is a list of things that if you tick them off, you are able to do. it's at the bottom of the page and all you have to do is
-make a tick next to "Can modify the Dock" by clicking the small white box next to it.
-restart your computer.

voila! :D

try it if you have "parental control" on your account.
Ah!

Thank you so much for that! You are a life saver! In fact, you don't need to restart your computer after changing these preferences. All you need to do is type
Code:
killall Dock
directly in the Terminal. (Just search for it in Finder or top right search bar.)

This helped me after restarting my dock to factory settings.
 

joe bongiovi

macrumors newbie
Jan 22, 2011
1
0
can't remove items from dock

I was having a major newbie headache with this problem...then I opened ONYX! In the "parameter" portion of ONYX there is an option to lock items in dock!!!

Deselect it and all should be well. I'm running Snowleopard OSX 10.6.6., and now the icons go "poof" again.

If this is a help I'd appreciate knowing.

Thanks ;>)
 
Last edited:

thecoolk

macrumors newbie
Jul 22, 2008
8
0
Solved

my problem was that I had parental controls on. if you think that might be the reason, go to:
System Preferences>Parental Controls>(and if Parental Controls are enabled)Open Parental Controls..>unclick 'Allow User to Modify the Dock'
hope this helps
 

mh33

macrumors newbie
Apr 11, 2013
1
0
This worked for me...

In the Terminal, which can be found by opening Finder and searching "Terminal" in the Applications folder, copy and paste the following:

defaults write com.apple.dock contents-immutable -bool false; killall Dock

Hopefully this helps you too!!
 

thx1212

macrumors newbie
Sep 17, 2017
1
0
To fix the problem your having your going to need to delete the following files

com.apple.dock.db
com.apple.dock.plist

They are located in

/Macintosh HD/Users/HOMEFOLDER/Library/Preferences/

once these files are deleted open terminal and type

killall Dock

Now move your mouse to the bottom of the screen and the Dock will relaunch back to its factory settings.
[doublepost=1505657816][/doublepost]THNAK YOU!! I have been trying to solve this problem for quite some time and your solution worked first time!!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.