Can't remove MyWi On demand!! HELP!!

Discussion in 'Jailbreaks and iOS Hacks' started by tsa1, Feb 4, 2011.

  1. tsa1 macrumors regular

    Nov 8, 2008
    Ok so downloaded the latest verson of mywi over my current. Tried uninstalling it and it uninstalled the actual mywi, but not the mywi on demand! I do not have openSSH or ifile on my phone so i cant uninstall it that way!

    I tried reinstalling mywi 4.0 but now cydia is saying it cannot locate it! I also cannot install iFile or openssh now because it wants to remove ondemand and thats where I get the error message!

    "subprocess pre-removal script returned error exit status 127"

    I think Im just going to restore back to 4.0.1 and rejailbreak!
  2. rsuryase macrumors newbie

    May 4, 2010
    Me too same error. 4.50 UI is messed up on iPad OS 3.2. Wanna downgrade but can't. Hope they fix it on next release.
  3. tsa1 thread starter macrumors regular

    Nov 8, 2008
  4. NoStopN macrumors 6502


    Jul 13, 2010
    Murfreesboro, TN
    My question is, why would you want to remove the OnDemand part of MyWi? Unless you paid $5 for the OnDemand upgrade, OnDemand normally doesn't cause any change from the previous version. If you DID pay for the upgrade, why would you want it removed?
  5. Zenobe macrumors newbie

    Feb 6, 2011
    Neither can I!

    I've been having this problem too, I'm still trying to delete MyWi OnDemand without any success. Is there a way to fix the problem by using OpenSSH, Iphone Browser, Terminal or iFile (Or any other way)? :confused:
  6. Zenobe, Feb 6, 2011
    Last edited by a moderator: Feb 6, 2011

    Zenobe macrumors newbie

    Feb 6, 2011
    Solved it!!

    I Finally solved the problem! Just download and install iFile

    1. Open Cydia and download iFile.
    2. CLOSE Cydia!
    3. Open iFile.
    3. Navigate to the top (first) folder.
    4. Scroll to the top and you'll see a search field.
    5. Search in "Hierarchy" mode for "MyWi".
    6. Delete all files containing the phrase "MyWi"
    7. Close iFile and open Cydia.
    8. Go to Manage > Packages > MyWi OnDemand > Modify > Remove

    Now it will remove it completely! :)
  7. britbloke macrumors newbie

    Jul 9, 2010
    Thanks for this! Was having lots of trouble trying to uninstall MyWi and this worked for me.
  8. haroonie macrumors newbie

    Jan 13, 2011
    this worked for me too, thanks!
  9. WhatAmI macrumors 6502a


    Sep 2, 2009
    Wow, glad this 'fixed' everyones major major problem but boy - you're asking for trouble resolving it this way...
  10. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    I agree.
    Leave it alone, even if you're not using it its installed there by default with MyWi and cannot be removed.
  11. Warzau macrumors newbie

    Mar 21, 2011
    Same thing here

    I had to register to say I have the same exact error, can't update, can't remove, can't add PDAnet because of error 127. Then I thought why don't I apply some Windows troubleshooting. I rebooted the iPhone into safe mode, went into Cydia, packages and removed it, voila, no error. Respring and went back into Cydia no mode, now I can install updated MyWi with no issues.
  12. sesshoumaru, Mar 23, 2011
    Last edited: Mar 23, 2011

    sesshoumaru macrumors newbie

    Mar 23, 2011
    Please help......slightly worse problem

    I am having the same problem, except, I also cannot install ANYTHING else through Cydia, because it keeps trying to uninstall MyWi which is queued. I tried "Clear" but that just does the same thing, tries to uninstall it. Any help would be much appreciated! I am almost at the last resort....i.e. jailbreaking. This couldn't come at a worse time, as I have a huge exam to study for. :(


    I got it to Clear from the queue, but still every time I try to add a new program through Cydia, it still shows up in the queue for removal, and again gives me a 127 error before installing the new program. What about manually deleting all the App.MyWi files directly through the command line? using rm etc ?


    Ok, I am able to install apps now, but cannot install any other HotSpot or WiFi type programs, as they need to FIRST uninstall MyWi. I have already tried all the methods posted in this thread, but to no avail. I REALLY need tethered internet, and don't want to have to upgrade my iOS. Again, ANY help would be much appreciated!


    GOOD GOD! Zenobe you are a genius. Your way actually worked well. I was damn skeptical, but it worked. I'm sure it is pretty dangerous, but I was kinda desperate and took a risk. It worked, and I have this god forsaken crap program off my iphone.

    I have a question now.......should I be untrustful of ALL packages and programs by Sinfulphonerepo?
  13. coupey, Mar 26, 2011
    Last edited: Mar 26, 2011

    coupey macrumors regular

    Sep 10, 2010
    sesshoumaru can you give me a quick hand? im having the same issues you are, i cant install ifile bc it keeps trying to remove mywi.

    i deleted the mywi file out of the applications via ssh.

    please tell me how you got ifile on the phone or got mywi off completely?

    got a buddy to send me via email and i ssh'd it into phone and did what zenobe said and it worked. thanks all.
  14. fillybisk macrumors newbie

    Mar 27, 2011
    Hi, all.

    I'm having the same problem removing On Demand. I have Ifile already on my phone. I'm following the directions and have done a search in hierarchy mode.

    THe list of all files containing "mywi" appears. Maybe I'm stupid, but I can't figure out how to actually delete these files. I don't see an edit button that allows me to select all the files and when I select an individual file, I don't see a delete button or trash can.

    Can someone please help?

  15. fillybisk macrumors newbie

    Mar 27, 2011
    With a pen and paper, I wrote down each file name and location and deleted each one individually. Everything worked fine, but I'm sure there must have been an easier way.
  16. AJCrowley macrumors newbie

    Mar 27, 2011
    Manually deleting the files is sketchy at best.

    1) To do it properly, reinstall MyWi if you've removed it.
    2) In a SSH session, cd /Applications/
    3) ./killer
    4) This will have killed all MyWi processes, now simply open Cydia, and uninstall the full MyWi bundle.

  17. vsuri macrumors newbie

    Jun 26, 2010
    This did *not* work for me.
  18. scirica macrumors 68020


    May 13, 2008
    Dallas, TX
    Interesting. I installed MyWi 4.0 today so I could share my internet with passengers in my car during a weekend road trip yesterday. It did install MyWi OnDemand at the same time. Tonight, I uninstalled but the trick was to uninstall MyWi OnDemand as the primary, and it automatically pulled MyWi 4.0 into the uninstall list. One respring, one reboot and they are gone and I'm back to just using TetherMe again.
  19. barshahar macrumors newbie

    Apr 5, 2011
    hi guys please help,
    when i try to remove MyWi on demand i getting error
    "subprocess pre-removal script returned error exit status 127"
    Sub-process /usr/bin/dpkg returned an error code (1)

    in addition i'm getting this error every time i trying to download something from Cydia because when i download something from Cydia it trying automatically to remove the "MyWi OnDemand" and getting this error...
    (I Cant download Ifile because of that)

    please help with fixing this problem!
  20. Zack-17 macrumors newbie

    Apr 13, 2011
    Can't get mywi ondemand off my phone! HELP!!

    HELPP!!! I can not remove mywi ondemand off my phone my phone keeps giving me a 127 error! I don't have ifile and can't get it because cydia will not let me get anything because it keeps trying to remove mywi ondemand but keeps geting the 127 error! Someone please help me!!
  21. barshahar macrumors newbie

    Apr 5, 2011
    got the same problem

    please help.
  22. complexchi macrumors newbie

    May 12, 2010
  23. flyingninjas macrumors member

    Jan 27, 2011
    do any of you guys have ssh, afc2add, or terminal installed?
  24. complexchi macrumors newbie

    May 12, 2010
    Yeah Open SSH doesn't that come with cydia?

Share This Page