Can't remove obsolete StartupItems

Discussion in 'OS X Yosemite (10.10)' started by josyoung, Jan 24, 2015.

  1. josyoung macrumors newbie

    Joined:
    Jan 24, 2015
    #1
    I'm new here, so apologies if I get the protocol wrong...

    My mac was running slowly, so I followed advice I got in other threads and ran Etrecheck.

    Got the following:

    Startup Items: ℹ️
    Freecorder: Path: /Library/StartupItems/Freecorder
    HWNetMgr: Path: /Library/StartupItems/HWNetMgr
    StartOuc: Path: /Library/StartupItems/StartOuc
    wpa_supplicant_srv: Path: /Library/StartupItems/wpa_supplicant_srv
    Startup items are obsolete in OS X Yosemite


    Sooo - went to try and move them (as advised) and can't find the path /Library/StartupItems

    Went to terminal and can see the folder StartupItems. Can also get onto it - but it seems to be empty.

    Tried to remove the folder in Terminal but was told it didn't exist.

    Re-ran Etrecheck in case I had magically deleted it - got the same errors.

    Any ideas?
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    Open Finder > Go to Folder > /Library/StartupItems. If you have any applications that are set to run at start, they should be there.
     
  3. josyoung thread starter macrumors newbie

    Joined:
    Jan 24, 2015
    #3
    Tried that...

    Thanks for this - I tried this and got the message "The folder can't be found" :confused:
     
  4. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #4
    Post the exact Terminal commands you used, and their complete output.

    Don't retype the commands in a reply here. Instead, launch Terminal, run the commands, select the entire text in the Terminal window, then copy and paste it into a reply here.

    Please use CODE tags around the Terminal text.

    Finally, tell us exactly which OS version you're using.
     
  5. josyoung, Jan 24, 2015
    Last edited: Jan 24, 2015

    josyoung thread starter macrumors newbie

    Joined:
    Jan 24, 2015
    #5
    Code:
    Last login: Sat Jan 24 18:02:34 on console
    Joannas-MBP:~ Joanna$ cd library
    Joannas-MBP:library Joanna$ ls
    Accounts		Fonts			PreferencePanes
    Address Book Plug-Ins	Fonts Disabled		Preferences
    Application Scripts	GameKit			Printers
    Application Support	Google			PubSub
    Assistant		Group Containers	Safari
    Assistants		Icons			Saved Application State
    Audio			IdentityServices	Screen Savers
    Caches			Input Methods		Services
    Calendars		Internet Plug-Ins	Social
    ColorPickers		Keyboard Layouts	Sounds
    Colors			Keychains		Spelling
    Compositions		LanguageModeling	SyncedPreferences
    Containers		LaunchAgents		Voices
    Cookies			Logs			WebKit
    Dictionaries		Mail			com.apple.nsurlsessiond
    Favorites		Messages		iMovie
    Filters			Metadata		iTunes
    FontCollections		Mobile Documents	openvpn
    Joannas-MBP:library Joanna$ 
    Hope I did that right? As you can see, the StartupItems directory isn't there now, which is odd - as it definitely WAS there. I then re-ran Etrecheck to make sure that the problem was still there - and got the same errors (as in the original thread...)

    Am using Yosemite 10.10.1
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    You're looking at your home folder's Library. The correct location is /Library. The leading slash is important.

    When you enter the location in the Finder's "Go to Folder" dialog, you must use exactly this, including the leading slash:
    /Library/StartupItems
    You can get the same effect using a Terminal command. Paste this into a Terminal window:
    Code:
    open /Library
    
    The Finder should open a window, and there should be a StartupItems folder in there.
     
  7. josyoung thread starter macrumors newbie

    Joined:
    Jan 24, 2015

Share This Page