Can't remove Tags in Mavericks

Discussion in 'OS X Mavericks (10.9)' started by steve23094, Mar 26, 2014.

  1. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #1
    Hello,

    I run OS X 10.9.2.

    I have never used tags under Mavericks, but I have noticed that three of my games are tagged. I never did it so I assume there has been a glitch somewhere along the line. Deus Ex: Human Revolution and Lego Harry Potter are tagged orange, Bioshock Infinite is tagged as gray.

    The problem is I cannot delete the tags. I can add and remove tags on other files so I understand how it is done. This seems to be a bug.

    You can see from the image below that there isn't even an option in the menu to add or remove a tag.

    [​IMG]

    I have tried deleting all tags and then reinstating them (from the sidebar in Finder) and bizarrely these three files retain their tags through this process. Does anyone know how to fix this?

    Thanks very much.
     
  2. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #2
    Try list view and clicking on the tags individually?
     
  3. chinajon macrumors newbie

    chinajon

    Joined:
    Feb 16, 2006
    Location:
    China
    #3
    I think this is a permissions problem. Go to the app, Command I and unlock the app. Press + to add yourself to the list. It will have (Me) next to it. Click that and change read only to read and write.
    lock the widow back up, and see if you now have access to the tags.
     
  4. steve23094 thread starter macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #4
    Hi,

    Yep, you were definitely onto something about the file permissions. The file has three users listed:-

    system (Read & Write)
    wheel (Read only)
    everyone (Read only)

    Adding myself to the list of users and then selecting 'Read & Write' didn't work, but elevating 'everyone' to 'Read & Write' did work. I was able to remove the tag and then reverted the file to it's original permissions. I'm guessing there is an order of execution where 'everyone' was overriding my personal permissions.

    No idea who 'wheel' is, but it's not important.

    Thanks for the help.
     
  5. bjprc macrumors newbie

    bjprc

    Joined:
    Feb 2, 2009
    Location:
    Beijing, China
    #5
    --- Post Merged, May 3, 2016 ---
    I am running El Capitan, the "no tag" had disappeared. No way to delete. Then I created a new tag "none" and it worked...
     
  6. CliftonHighgrov macrumors regular

    CliftonHighgrov

    Joined:
    Oct 1, 2014
    Location:
    United Kingdom

Share This Page