Can't repair permissions

Discussion in 'macOS Sierra (10.12)' started by paceyj, Jan 7, 2017.

  1. paceyj macrumors newbie

    Joined:
    Jan 7, 2017
    #1
    Hey, hope someone can help.

    Pages has stopped being able to export or save-as. I did some googling and found that I need to repair my permissions. From the recovery screen, I loaded repairhomepermissions and tried to do so, but it told me 'Repair Failed'.

    Any ideas?
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    I believe this terminal command works in 10.11:
    sudo /usr/libexec/repair_packages --repair --standard-pkgs /

    BUT... I have no idea if it works in 10.12.

    Worth a try.
     
  3. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #3
    Repair Permissions won't fix that problem. It actually only fixes a few issues... most of which people never have. The act of restarting after repairing permissions is usually what fixes the problem.

    Not only that, but there is no need for running a repair permission command because SIP prevents permissions issues from occurring to begin with... that's why it's no longer in Disk Utility.

    In short, Repair Permissions is, and always has been a mostly placebo. A sugar pill that did absolutely nothing for 99.99% of the people using it.

    In your case, I would try deleting prefs for Pages, and at worst re-installing Pages completely.
     
  4. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #4
    I do is every so often using TechTool Pro.

    Lou
     
  5. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #5
    You are referring to the old "Repair Permissions" which used to be in Disk Utility now removed. This did not repair Home directory permissions, which is what the OP is asking about. Repairing Home Directory permissions can be done as he said by booting from the Recovery Partition as here for example.
    Recently Apple have published this KB which seems to offer a different way of resetting Home directory permissions, but I have never tried this.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    That permissions repair method from your first link is gone in Sierra. I think the only way now is in Terminal from your second link.
     
  7. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #7
    Thanks....explains why there is a new method in Sierra, and why the RP method didn't work for the OP.
     

Share This Page